1 Reply Latest reply on Sep 22, 2003 2:51 PM by Stephane Nicoll

    Error starting JBoss with MDB deployed

    rshahinian Newbie

      When starting JBoss

      [3.2.1 (build: CVSTag=JBoss_3_2_1 date=200305041533)]

      with some MDB already deployed, the following output appears:

      11:52:22,825 INFO [JMSContainerInvoker] Starting
      11:52:22,835 ERROR [JMSContainerInvoker] Starting failed
      javax.naming.NameNotFoundException: DefaultJMSProvider not bound
      at org.jnp.server.NamingServer.getBinding(NamingServer.java:495)
      at org.jnp.server.NamingServer.getBinding(NamingServer.java:503)
      at org.jnp.server.NamingServer.getObject(NamingServer.java:509)
      .....
      .....
      .....


      followed by:

      11:52:23,245 ERROR [MessageDrivenContainer] Starting failed
      javax.naming.NameNotFoundException: DefaultJMSProvider not bound
      at org.jnp.server.NamingServer.getBinding(NamingServer.java:495)
      at org.jnp.server.NamingServer.getBinding(NamingServer.java:503)

      ...
      ...


      After

      11:52:29,865 INFO [JMSProviderLoader] Starting
      11:52:29,895 INFO [JMSProviderLoader] Bound adapter to java:/DefaultJMSProvider
      11:52:29,895 INFO [JMSProviderLoader] Started

      resulted by deploy/jms/jms-ds.xml

      we get the bottom line:

      MBeans waiting for other MBeans:
      [ObjectName: jboss.j2ee:jndiName=local/test/TestMessage,service=EJB
      state: FAILED
      I Depend On:
      Depends On Me: javax.naming.NameNotFoundException: DefaultJMSProvider not bound]


      To have the TestMessage running properly it must be redeployed.

      I don't know about the requirements on server startup, but such a behavior isn't nice.

      Waiting for responses,

      Razmik.