5 Replies Latest reply on Oct 9, 2003 5:56 AM by Adrian Brock

    JMS problems on JBoss 4.0 DR2

    lbalazs Newbie

      Hi!

      (I have already posted the same on the developer forums when i realized it was the wrong place. sorry for that.)

      I am developing an asynchronous J2EE app using the timer service and JMS, and since the standard timerservice is only available in JBoss 40 as far as I know, i have tried it.

      Well, i have massive problems to use the JMS facility: My beans get deployed, but i cant post any message from the outside to them with the same code which worked on 3.2.1. (Of course, recompiled with the new libraries, etc.)

      My questions are:
      - What has changed on the JMS, btw. what settings should i change to make it work?
      - Is there a possibility to upgrade 3.2.1 with the TimerService?
      - Will there be a new DR available in the near future (2 weeks) which fixes the problems (if there are any) ?


      Details to the above JMS Error:

      If I post a msg from the outside to a JMS topic (with auto_ack), the client succeds without errors, and the server produces the following trace:

      00:33:34,698 WARN [SpyMessageConsumer] Error in getMessage()
      javax.jms.JMSException: Invalid transaction id.
      at org.jboss.mq.SpyXAResourceManager.ackMessage(SpyXAResourceManager.java:72)
      at org.jboss.mq.SpyMessageConsumer.preProcessMessage(SpyMessageConsumer.java:714)
      at org.jboss.mq.SpyMessageConsumer.getMessage(SpyMessageConsumer.java:677)
      at org.jboss.mq.SpyMessageConsumer.receive(SpyMessageConsumer.java:190)
      at org.jboss.resource.adapter.jms.MessageDelegate.run(MessageDelegate.java:60)
      at org.jboss.resource.work.WorkHolder.run(WorkHolder.java:143)
      at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(PooledExecutor.java:727)
      at java.lang.Thread.run(Thread.java:534)

      But only on the first message, and it seems to ignore any msg afterwards.

      Many thanks in advance,
      Balazs

        • 1. Re: JMS problems on JBoss 4.0 DR2
          Adrian Brock Master

          The timerservice? Do you mean the jmx timer or the ejb timer?
          The jmx timer is in 3.2
          The ejb timer is part of ejb2.1 and won't be backported to 3.2
          which will always stay at ejb2.0

          Regards,
          Adrian

          • 2. Re: JMS problems on JBoss 4.0 DR2
            lbalazs Newbie

            Thanks for the fast response.

            I mean the EJB 2.1 TimerService.

            If it wont be backported to 3.2.2, then i will try to use 4.0. Btw., am i doing anything wrong, is the failure described an error known to the current DR2? If not, it would be very fine if i could get some advice to find the reason for the error.

            When can i expect a new DR? In the roadmap, it was projected to september, i think.

            Thanks,
            Balazs

            • 3. Re: JMS problems on JBoss 4.0 DR2
              Adrian Brock Master

              The JMS problem has already been fixed.

              The 4.0DR2 code has been rolled back 3.2, the EJB Timer
              and MDB code was one example of experimental code
              that we need to rollback.

              The problem with the timer you are testing is that it does not
              work in a clustered environment.

              Regards,
              Adrian

              • 4. Re: JMS problems on JBoss 4.0 DR2
                wizzie Newbie

                Adrian, can you please explain how to rollback the code?
                We are trying to use new JCA in 4.0 and apparantly nothing works due to JMS problems, described above.

                PS
                The example source code (i.e. chapter 6, example 2) gives the very same exeption

                • 5. Re: JMS problems on JBoss 4.0 DR2
                  Adrian Brock Master

                  We have already rolled back JBossMQ to the stable 3.2 code
                  in 4.0 - We have also rolled back the JCA1.5 changes.
                  I still need to go through that code to check what is stable
                  and what needs fixing before reapplying it.

                  You could try replacing the 4.0 jbossmq.jar with the 3.2 version,
                  I can't guarantee it will work?

                  Regards,
                  Adrian