3 Replies Latest reply on Nov 13, 2003 7:32 PM by Adrian Brock

    OutOfMemoryError with UIL2 on Solaris

    David Hosier Novice

      We have a customer that is getting multiples of the following error in JBoss:

      2003-11-11 13:09:37,664 ERROR [org.jboss.mq.il.uil2.SocketManager] Exiting on unexpected error in read task
      java.lang.OutOfMemoryError
      2003-11-11 13:09:37,664 WARN [org.jboss.mq.server.ClientConsumer] Could not send messages to a receiver.
      java.lang.reflect.UndeclaredThrowableException
      at org.jboss.mq.il.uil2.msgs.BaseMsg.setError(BaseMsg.java:301)
      at org.jboss.mq.il.uil2.SocketManager$ReadTask.run(SocketManager.java:311)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.OutOfMemoryError
      2003-11-11 13:09:37,672 ERROR [org.jboss.mq.server.JMSDestinationManager] The connection to client ID:24 failed.

      They are running the server on Solaris. Here is the output of a uname -a command:

      SunOS netxprd1 5.8 Generic_108528-23 sun4u sparc SUNW,Netra-T12

      The machine has 8 processors if that helps at all.

      We cannot duplicate this error at our office. I have tried sending a JMS message larger than any message they would be getting, I tried opening more client applications than they have ever opened, and I have tried sending 9000+ small messages....nothing causes the problem.

      Does anyone have an idea of what could cause this problem?

      Thanks! Please let me know if more information may be helpful.

      -David