1 Reply Latest reply on Mar 29, 2004 7:19 AM by Adrian Brock

    Help - Failed to deploy MDB

    ev sh Newbie

      Hello All,
      Had a problem deploying an MDB.

      When i deployed it and sent messages to the queue it listen on i didn't recieve anything.

      Then i tried the oposite. first put some messages in a queue , then deploy the MDB. what i got was a bunch of stack traces in the JBoss console (come on guys...).

      javax.jms.JMSException: Invalid transaction id.
      at org.jboss.mq.SpyXAResourceManager.ackMessage(SpyXAResourceManager.java:72)
      at org.jboss.mq.SpyMessageConsumer.preProcessMessage(SpyMessageConsumer.java:714)
      at org.jboss.mq.SpyMessageConsumer.receive(SpyMessageConsumer.java:168)
      at org.jboss.resource.adapter.jms.MessageDelegate.run(MessageDelegate.java:60)
      at org.jboss.resource.work.WorkHolder.run(WorkHolder.java:143)
      at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(PooledExecutor.java:727)
      at java.lang.Thread.run(Thread.java:536)
      06:50:10,406 INFO [MessageDelegate] Message receive failed.
      javax.jms.JMSException: Another thread is already in receive.
      at org.jboss.mq.SpyMessageConsumer.receive(SpyMessageConsumer.java:139)
      at org.jboss.resource.adapter.jms.MessageDelegate.run(MessageDelegate.java:60)
      at org.jboss.resource.work.WorkHolder.run(WorkHolder.java:143)
      at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(PooledExecutor.java:727)
      at java.lang.Thread.run(Thread.java:536)



      Any idea?

      Thanx.