1 Reply Latest reply on Aug 2, 2004 10:41 PM by Amir Gur

    Problems with setting clustering for JBossMQHA

    Amir Gur Newbie

      Hi,

      We are trying to get clustering and failover for JMS.
      And working according http://www.jboss.org/wiki/Wiki.jsp?page=JBossMQHA

      I have done the following:

      1. Two instances of JBoss 3.2.5.

      2. One mysql 4.0. Both servers are pointed to the same database as suggested. Removed hsqldb-jdbc2-service.xml and added mysql-jdbc2-service.xml. Configured mysql-ds.xml to point to my database.
      cd $JBOSS_HOME/server/all
      cp ../../docs/examples/jms/mysql-jdbc2-service.xml deploy-hasingleton/jms/
      rm deploy-hasingleton/jms/hsqldb-jdbc2-service.xml
      cp [some_dir/]mysql-connector-java-3.0.11-stable-bin.jar lib
      cp ../../docs/examples/jca/mysql-ds.xml deploy/
      vi deploy/mysql-ds.xml - set database / user/password.

      3. Running the all configuration. (~/jboss/jboss-3.2.5/bin/run.sh -Djboss.bind.address=10.2.2.5 -Djava.rmi.server.hostname=`hostname` -c all)

      4. Both servers show the below, which is not a good sign.
      18:23:10,073 INFO [DefaultPartition] Number of cluster members: 1
      18:23:10,073 INFO [DefaultPartition] Other members: 0

      5. Both servers MBean jboss.ha:HASingletonDeployer have MasterNode = True.

      6. Deployed the client on qa separate JBoss machine (also 3.2.5). But running the client steps (below) don't seem capable of fixing the HASingletonDeployer issue.
      # Locate the MBean jboss.mq.examples:HAJMSClient
      # Run operation connectPublisher
      # Run operation registerDurableSubscriberAndDisconnect
      # Run operation publishMessageToTopic passing a test message (e.g. "TestHAJMS1?")
      # See the value of attribute LastMessage?; It should be null

      7. A more interesting test is the trivial multicast test which comes with JGroups. This one works fine on those two machines. I am using the same ip and ports as the default JBoss uses for JGroups.
      java org.jgroups.tests.McastSenderTest -mcast_addr 228.1.2.3 -port 45566
      java org.jgroups.tests.McastReceiverTest -mcast_addr 228.1.2.3 -port 45566

      8. By the way this test eliminated the need to add a route for linux as described in JBossClustering_7x9.pdf. (route add -net 224.0.0.0 netmask 240.0.0.0 dev eth0). Though needless to say, I have tried to add the route and rerun my servers to no avail.

      9. I also tried supplying TCP for JGroups. JBossClustering_7x9.pdf has a mistake in which it puts pbcast.STABLE before pbcast.NAKACK. It took me some time to get to Scott Stark's comment about it at: http://www.mail-archive.com/jboss-development@lists.sourceforge.net/msg39371.html//www.mail-archive.com/jboss-development@lists.sourceforge.net/msg39371.html.

      10. Searching the forums, nothing useful showed up.

      11. Using the "<!-- Clustering logging -->" section of log4j.xml I cannot see why is my configuration wrong. I will try to attach the log-file separately in hope it would help identifying the issue.

      Clustering for HAJMS obviously does not work. Though, it should be working out of the box as described in the documentation.

      Your help will be appreciated,

      Amir