7 Replies Latest reply on Oct 20, 2004 1:57 PM by Justin Haddad

    Can't initialize MessageCounterHistoryDayLimit to zero

    Justin Haddad Newbie

      While analyzing the performance of my app, which runs on JBoss 3.2.5, I noticed significant cpu usage eaten up by my JMS queue's message history counter. I figured I could easily disable this by setting the MessageCounterHistoryDayLimit to zero, as show in the descriptor below. This resulted in a NullPointerException at startup caused by the jmx config service calling a setter on the underlying queue object before it was instantiated. Is there another way that I should disable this count history feature?

       <mbean code="org.jboss.mq.server.jmx.Queue"
       name="jboss.mq.destination:service=Queue,name=RequestQueue">
       <depends optional-attribute-name="DestinationManager">jboss.mq:service=DestinationManager</depends>
       <attribute name="MessageCounterHistoryDayLimit">0</attribute>
       <attribute name="InMemory">true</attribute>
       </mbean>