0 Replies Latest reply on Apr 5, 2005 12:29 PM by Sriram Padmanabhan

    XAConnectionFactory not bound

    Sriram Padmanabhan Newbie

      Hello,
      I dont understand why this error is happening. I have a oracle database with JBOSS. I also have a MDB im my application. The application is connecting to the database perfectly. I guess while connecting to JMS I am getting an error. But when I am trying to look up a connection factory I am getting an error. Can you guys please help me out. I am pasting the config files below as well as a small part of application log. Please help me out!!!!!

      This is my standardjaws.xml( I mean part relevant to the problem)


      java:/OracleDS
      <type-mapping>Oracle9i</type-mapping>
      false
      <default-entity>
      <create-table>true</create-table>
      <remove-table>false</remove-table>
      <tuned-updates>true</tuned-updates>
      <read-only>false</read-only>
      <time-out>300</time-out>
      <row-locking>false</row-locking>
      <read-ahead>false</read-ahead>
      </default-entity>
      .................


      This is my relevant standardjbosscmp-jdbc.xml

      java:/OracleDS
      <datasource-mapping>Oracle9i</datasource-mapping>

      This is my relevant part of jbossmq-destinations-service.xml



      <depends optional-attribute-name="DestinationManager">jboss.mq:service=DestinationManager
      <depends optional-attribute-name="SecurityManager">jboss.mq:service=SecurityManager









      The login-config.xml contents are

      <application-policy name = "OracleDbRealm">

      <login-module code = "org.jboss.resource.security.ConfiguredIdentityLoginModule" flag = "required">
      <module-option name = "principal">sa</module-option>
      <module-option name = "userName">sa</module-option>
      <module-option name = "password"></module-option>
      <module-option name = "managedConnectionFactoryName">jboss.jca:service=LocalTxCM,name=OracleDS</module-option>
      </login-module>

      </application-policy>


      The sample piece of code I am trying to access the Message Bean from a Enterprise bean.

      Context ctxInitCtxt = new InitialContext();
      TopicConnectionFactory factory = (TopicConnectionFactory)ctxInitCtxt.lookup("ConnectionFactory");
      TopicConnection topicConn = factory.createTopicConnection();
      TopicSession topicSession = topicConn.createTopicSession(false, Session.AUTO_ACKNOWLEDGE);
      Topic topic = (Topic) ctxInitCtxt.lookup("topic/DEFTopic");
      TopicPublisher publisher = topicSession.createPublisher(topic);
      ObjectMessage objMsg =topicSession.createObjectMessage();
      objMsg.setObject(dfrep);
      publisher.publish(objMsg);
      strClassName=this.getClass().getName();


      Regards
      Sriram.P