6 Replies Latest reply on Aug 14, 2006 8:09 PM by Arthur Vernon

    JMS ProviderFailure:java.lang.NoSuchFieldError

    Premlatha Sundararajan Newbie

      I am attempting to integrate TIBCO and Jboss4.0.2RC1 through JMS in vain

      I've scruplously followed the documentations given below for the same, not to mention , searching on the net as well as these forums :
      1. TIBCO Enterprise Message Service?Application Integration Guide Software Release 4.2
      2. http://www.jboss.org/wiki/wiki.jsp?page=HowDoIConfigureAnMDBToTalkToARemoteQueue

      jms-ds.xml

      <?xml version="1.0" encoding="UTF-8"?>
      <connection-factories>
       <mbean code="org.jboss.jms.jndi.JMSProviderLoader" name="jboss.mq:service=JMSProviderLoader,name=TibjmsProvider">
       <attribute name="ProviderName">TIBCOJMSProvider</attribute>
       <attribute name="ProviderAdapterClass">com.tibco.tibjms.appserver.jboss.JBossAdapter</attribute>
       <attribute name="QueueFactoryRef">XAQueueConnectionFactory</attribute>
       <attribute name="TopicFactoryRef">XATopicConnectionFactory</attribute>
       </mbean>
      
       <!-- Redirect QueueConnectionFactory to TIBCO Enterprise for JMS -->
       <mbean code="org.jboss.naming.NamingAlias" name="DefaultDomain:service=NamingAlias,fromName=QueueConnectionFactory">
       <attribute name="ToName">tibjmsnaming://localhost:7222/XAQueueConnectionFactory</attribute>
       <attribute name="FromName">QueueConnectionFactory</attribute>
       </mbean>
      
       <!-- The server session pool for Message Driven Beans -->
       <mbean code="org.jboss.jms.asf.ServerSessionPoolLoader" name="jboss.mq:service=ServerSessionPoolMBean,name=StdJMSPool">
       <depends optional-attribute-name="XidFactory">jboss:service=XidFactory</depends>
       <attribute name="PoolName">StdJMSPool</attribute>
       <attribute name="PoolFactoryClass">org.jboss.jms.asf.StdServerSessionPoolFactory</attribute>
       </mbean>
      </connection-factories>
      


      ERROR

      .
      .
      .
      .
      12:09:38,520 INFO [WrapperDataSourceService] Bound connection factory for resource adapter for Conn
      12:09:38,551 WARN [ConfiguredIdentityLoginModule] Creating LoginModule with no configured password!
      12:09:39,567 INFO [EjbModule] Deploying UserProfile
      12:09:39,738 INFO [EjbModule] Deploying Role
      12:09:39,754 INFO [EjbModule] Deploying ClientControllerJNDI
      12:09:39,770 INFO [EjbModule] Deploying ReportManager
      12:09:39,801 INFO [EjbModule] Deploying UserProfileManager
      12:09:39,817 INFO [EjbModule] Deploying ApplicationManager
      12:09:39,832 INFO [EjbModule] Deploying RoleManager
      12:09:39,832 INFO [EjbModule] Deploying SecurityManager
      12:09:39,848 INFO [EjbModule] Deploying JMSWorkflowApplicationGateway
      12:09:40,207 WARN [JMSContainerInvoker] JMS provider failure detected:
      java.lang.NoSuchFieldError: providerURL
       at com.tibco.tibjms.appserver.jboss.JBossAdapter.getInitialContext(JBossAdapter.java:44)
       at org.jboss.ejb.plugins.jms.JMSContainerInvoker.innerCreate(JMSContainerInvoker.java:646)
       at org.jboss.ejb.plugins.jms.JMSContainerInvoker.startService(JMSContainerInvoker.java:862)
       at org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanSupport.java:272)
       at org.jboss.system.ServiceMBeanSupport.jbossInternalLifecycle(ServiceMBeanSupport.java:222)
       at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
      .
      .
      .
      12:11:45,690 ERROR [URLDeploymentScanner] Incomplete Deployment listing:
      MBeans waiting for other MBeans:
      ObjectName: jboss.mq:service=InvocationLayer,type=HTTP
       state: CONFIGURED
       I Depend On: jboss.mq:service=Invoker
       jboss.web:service=WebServer
      
       Depends On Me:
      ObjectName: jboss.mq:service=InvocationLayer,type=JVM
       state: CONFIGURED
       I Depend On: jboss.mq:service=Invoker
      
       Depends On Me:
      ObjectName: jboss.mq:service=InvocationLayer,type=UIL2
       state: CONFIGURED
       I Depend On: jboss.mq:service=Invoker
      
       Depends On Me:
      
      MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM:
      ObjectName: jboss.mq:service=Invoker
       state: NOTYETINSTALLED
       I Depend On:
       Depends On Me: jboss.mq:service=InvocationLayer,type=HTTP
       jboss.mq:service=InvocationLayer,type=JVM
       jboss.mq:service=InvocationLayer,type=UIL2
      
      
      12:11:45,831 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-0.0.0.0-8180
      12:11:45,893 INFO [ChannelSocket] JK2: ajp13 listening on /0.0.0.0:8109
      12:11:45,909 INFO [JkMain] Jk running ID=0 time=0/32 config=null
      12:11:45,909 INFO [Server] JBoss (MX MicroKernel) [4.0.2RC1 (build: CVSTag=JBoss_4_0_2_RC1 date=200
      12:11:55,221 INFO [JMSContainerInvoker] Trying to reconnect to JMS provider
      12:11:55,221 WARN [JMSContainerInvoker] JMS provider failure detected:
      java.lang.NoSuchFieldError: providerURL
       at com.tibco.tibjms.appserver.jboss.JBossAdapter.getInitialContext(JBossAdapter.java:44)
       at org.jboss.ejb.plugins.jms.JMSContainerInvoker.innerCreate(JMSContainerInvoker.java:646)
       at org.jboss.ejb.plugins.jms.JMSContainerInvoker.startService(JMSContainerInvoker.java:862)
       at org.jboss.ejb.plugins.jms.JMSContainerInvoker$ExceptionListenerImpl.run(JMSContainerInvok
       at java.lang.Thread.run(Thread.java:534)
      .
      .
      .
      

      if i add
      <attribute name="ProviderUrl">tibjmsnaming://localhost:7222</attribute>
      to the jms-ds.xml i get the following error

      .
      .
      .
      ,459 INFO [ServiceConfigurator] Problem configuring service jboss.mq:name=TibjmsProvider,service=JMSProviderLoader
      s.deployment.DeploymentException: No Attribute found with name: ProviderUrl
      at org.jboss.system.ServiceConfigurator.configure(ServiceConfigurator.java:263)
      at org.jboss.system.ServiceConfigurator.internalInstall(ServiceConfigurator.java:164)
      at org.jboss.system.ServiceConfigurator.install(ServiceConfigurator.java:118)
      at org.jboss.system.ServiceController.install(ServiceController.java:200)
      at sun.reflect.GeneratedMethodAccessor48.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:144)
      .
      .
      .
      12:27:34,037 INFO [EjbModule] Deploying UserProfile
      12:27:34,209 INFO [EjbModule] Deploying Role
      12:27:34,225 INFO [EjbModule] Deploying ClientControllerJNDI
      12:27:34,240 INFO [EjbModule] Deploying ReportManager
      12:27:34,272 INFO [EjbModule] Deploying UserProfileManager
      12:27:34,303 INFO [EjbModule] Deploying ApplicationManager
      12:27:34,303 INFO [EjbModule] Deploying RoleManager
      12:27:34,318 INFO [EjbModule] Deploying SecurityManager
      12:27:34,318 INFO [EjbModule] Deploying JMSWorkflowApplicationGateway
      12:27:34,662 WARN [JMSContainerInvoker] JMS provider failure detected:
      javax.naming.NameNotFoundException: TIBCOJMSProvider not bound
       at org.jnp.server.NamingServer.getBinding(NamingServer.java:491)
       at org.jnp.server.NamingServer.getBinding(NamingServer.java:499)
      


      what have i missed out, or where have i gone wrong....
      ps: invoker bindings were taken care of in both jboss.xml and standardjboss.xml...

      Thank you for your time