2 Replies Latest reply on Jan 17, 2006 8:30 AM by tdevos

    Connect JBoss 3.2.5 with JBoss 4.0.3 JMS

    tdevos Newbie

      Hi,

      All our customers are working with JBoss 3.2.5 on their location. They communicate with each other over JMS. All communication between our customers is forwarded to a central JBoss 3.2.5 server wich validates and forwards the JMS message to another JBoss 3.2.5 server. Until now we had no problems since all servers are JBoss 3.2.5. However, some customers want to update to JBoss 4.0.3. This introduces a problem that the JAR files are not in sync.

      Is there a way to connect JBoss 3.2.5 to 4.0.3 and vice versa. The problem is that the beans deployed on the servers are also sending JMS messages so they need to have the right JAR files. Maybe there is some kind "tunneler" which I can run on the central server to forward the JBoss 4.0.3 messages to 3.2.5.

      Does anybody have experience connecting 2 different versions of JBoss regarding JMS.

      Thanks in advance for replying.

      Tim De Vos