1 Reply Latest reply on Jun 29, 2006 4:55 PM by Steven Buberl

    Connecting to remote server fails

    Steven Buberl Newbie

      I've seen the FAQs about setting up a MDB to listen to messages from a remote server. When I try to deploy it, it says:

      5:19:15,638 INFO [EjbModule] Deploying CHARTEvents
      15:21:21,327 WARN [JMSContainerInvoker] JMS provider failure detected for CHARTEvents
      javax.naming.CommunicationException: Could not obtain connection to any of these urls: jmsTest:8093 and discovery failed with error: javax.naming.CommunicationException: Receive timed out [Root exception is java.net.SocketTimeoutException: Receive timed out] [Root exception is javax.naming.CommunicationException: Failed to retrieve stub from server jmsTest:8093 [Root exception is java.io.EOFException]]
      at org.jnp.interfaces.NamingContext.checkRef(NamingContext.java:1414)
      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:594)
      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:587)
      at javax.naming.InitialContext.lookup(InitialContext.java:351)
      at org.jboss.ejb.plugins.jms.DLQHandler.createService(DLQHandler.java:192)
      at org.jboss.system.ServiceMBeanSupport.create(ServiceMBeanSupport.java:188)
      at org.jboss.ejb.plugins.jms.JMSContainerInvoker.innerStartDelivery(JMSContainerInvoker.java:510)
      at org.jboss.ejb.plugins.jms.JMSContainerInvoker.startService(JMSContainerInvoker.java:839)
      at org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanSupport.java:289)
      at org.jboss.system.ServiceMBeanSupport.jbossInternalLifecycle(ServiceMBeanSupport.java:245)
      ... and so on for many, many more lines


      ("jmsTest" is the name on our DNS for the wanted server and I tried putting in the actual IP and that failed too.)

      Here's my mean configuration in jms-ds.xml:
      <mbean code="org.jboss.jms.jndi.JMSProviderLoader" name="jboss.mq:service=JMSProviderLoader,name=CHARTJMSProvider,server=jmsTest">
       <attribute name="ProviderName">CHARTJMSProvider</attribute>
       <attribute name="ProviderAdapterClass">
       org.jboss.jms.jndi.JNDIProviderAdapter
       </attribute>
       <attribute name="FactoryRef">java:/XAConnectionFactory</attribute>
       <attribute name="QueueFactoryRef">java:/XAConnectionFactory</attribute>
       <attribute name="TopicFactoryRef">java:/XAConnectionFactory</attribute>
       <attribute name="Properties">
       java.naming.factory.initial=org.jnp.interfaces.NamingContextFactory
       java.naming.factory.url.pkgs=org.jboss.naming:org.jnp.interfaces
       java.naming.provider.url=jmsTest:8093
       </attribute>
       </mbean>
      


      And I know the server is running fine, because I have a standalone, non-bean message listener that connects to that server on that port and reads the messages just fine.

      Anyone have any idea of what could be causing this? Any help would be greatly appreciated.

      Thanks.