0 Replies Latest reply on Aug 21, 2006 4:06 AM by Stefan Denk

    Which files must be provided to connect JBoss 4.0.2 to SAP X

    Stefan Denk Newbie

      Hi!

      I am currently trying to get SAP XI to talk to JBoss 4.0.2 via its JMS Adapter.

      To do that, I need to provide XI with the drivers from JBoss.

      Unluckily I am totally new to JBoss (let alone Java development), so I am asking you for the files needed to do the job.

      In an SAP Forum I read that the files were

      jboss-j2ee.jar (which I found in the 4.0.2 release I downloaded)
      dom4j-full.jar (I only found dom4j.jar)
      jms.jar (I only found jms-ra.rar, containing jms-ra.jar and other files)

      Trying it with these three I found (the ones in the brackets) caused the SAP XI's J2EE Engine to freeze - recovery is currently running.

      Can you help me? It would be great not to freeze the machine again on second try.... :o(


      Cheers!

      Stefan