3 Replies Latest reply on Sep 30, 2008 11:29 AM by Adrian Brock

    Problems changing DefaultDS

    Dave Rathnow Novice

      I originally posted this in the JCA forum but it was suggested that I post it here. So, here it is...

      JBoss Version is 4.2.0.GA

      I searched the Wiki and forums for a solution to this problem. I've seen two other posts with the same problem but nobody responded with a solution to I'll try.

      I'm trying to change the DefaultDS datasource from hsql to Oracle. I've followed the instructions I found in the wiki at http://wiki.jboss.org/auth/wiki/ConfigJBossMQDB?action=e&windowstate=normal&mode=view.

      All the JMS tables are being created but the KeyGeneratorFactory fails to deploy. I get the following stack trace in the log:

      2008-09-26 08:35:26,847 DEBUG [org.jboss.ejb.plugins.keygenerator.hilo.HiLoKeyGeneratorFactory] Starting jboss:service=KeyGeneratorFactory,type=HiLo
      2008-09-26 08:35:26,863 DEBUG [org.jboss.ejb.plugins.keygenerator.hilo.HiLoKeyGeneratorFactory] Executing SQL: select HIGHVALUES from HILOSEQUENCES where SEQUENCENAME='general'
      2008-09-26 08:35:26,894 DEBUG [org.jboss.ejb.plugins.keygenerator.hilo.HiLoKeyGeneratorFactory] Starting failed jboss:service=KeyGeneratorFactory,type=HiLo
      java.sql.SQLException: ORA-00942: table or view does not exist

      at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
      at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:331)
      at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:288)
      at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:743)
      at oracle.jdbc.driver.T4CStatement.doOall8(T4CStatement.java:207)
      at oracle.jdbc.driver.T4CStatement.executeForDescribe(T4CStatement.java:790)
      at oracle.jdbc.driver.OracleStatement.executeMaybeDescribe(OracleStatement.java:1037)
      at oracle.jdbc.driver.T4CStatement.executeMaybeDescribe(T4CStatement.java:830)
      at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1132)
      at oracle.jdbc.driver.OracleStatement.executeQuery(OracleStatement.java:1272)
      at org.jboss.resource.adapter.jdbc.WrappedStatement.executeQuery(WrappedStatement.java:171)
      at org.jboss.ejb.plugins.keygenerator.hilo.HiLoKeyGeneratorFactory.initSequence(HiLoKeyGeneratorFactory.java:320)
      at org.jboss.ejb.plugins.keygenerator.hilo.HiLoKeyGeneratorFactory.startService(HiLoKeyGeneratorFactory.java:281)


      If anyone is interested in the entire stack trace I will post it.

      Can anyone tell me what I need to do to get this to fix this?

      Thanks,
      Dave.

        • 1. Re: Problems changing DefaultDS
          Jay Howell Apprentice

          This is not an MQ problem. This is a problem in the UUID generator for EJBs.(hence the org.jboss.ejb.plugins....). Please don't cross post issues into forums, until you have gotten an answer from the other. This is not a JCA issue and it's not an MQ issue. It's an EJB issue. Can you please close out your other JCA post, so someone doesn't look up the answer on the other forum.

          The problem that you are facing is probably in your server/default/deploy/uuid-key-generator.sar/META-INF/jboss-service.xml file. This file uses a datasource. If you have removed your DefualtDS or you have changed it so it doesn't work, you need to change the line in the file mentioned above to match your datasource.

          <depends optional-attribute-name="DataSource">jboss.jca:service=DataSourceBinding,name=DefaultDS

          Jay:)

          • 2. Re: Problems changing DefaultDS
            Dave Rathnow Novice

            Jay,

            This whole thing started because of something I read from the WIKI that specifically targeted JBossMQ. After I tried to solve the problem, it looked like it went beyond JBossMQ, hence my post to the JCA forum. Somebody there suggested I post here.

            Since you are obviously aware that I posted in JCA, perhaps you might go and actually read the post and the responses I got.

            I have not removed my DefaultDS. All I did was change it from HSQL to Oracle as was documented in the WIKI. I did find the file you pointed out and fixed that problem but then something else broke.

            I'm not the first person who has run into this. I've found other posts with similar problem but nobody responded.

            Thanks for you help,
            Dave

            • 3. Re: Problems changing DefaultDS
              Adrian Brock Master

               

              "drathnow" wrote:

              I'm not the first person who has run into this.


              That's why there is an FAQ, you can see it referenced from at least
              two FAQ pages at the bottom.
              http://wiki.jboss.org/auth/wiki/ChangeTheDatabase


              I've found other posts with similar problem but nobody responded.

              Thanks for you help,
              Dave


              You are your own worst enemy.

              All posts like this that nobody answers because they are just repeated FAQs
              obscure those posts where it is answered.
              If I had my way, I'd just delete these lazy questions so as not to pollute the search index.