2 Replies Latest reply on Nov 20, 2008 3:41 AM by rlaenen

    Configuring JbossAS resource

    rlaenen Newbie

      Hi all,

      I've a problem with autodiscovery of a JBossAS server by the agent.
      I'm getting the following errors in the log :

      2008-11-14 10:30:25,468 DEBUG [InventoryManager.discovery-1] (rhq.core.pc.plugin.PluginComponentFactory)- Loading class: org.rhq.plugins.jbossas.JBossASDiscoveryComponent
      2008-11-14 10:30:25,483 DEBUG [InventoryManager.discovery-1] (rhq.core.pc.plugin.PluginComponentFactory)- Loaded class: class org.rhq.plugins.jbossas.JBossASDiscoveryComponent
      2008-11-14 10:30:25,483 DEBUG [InventoryManager.discovery-1] (rhq.core.pc.plugin.PluginComponentFactory)- Loading and creating the discovery component [org.rhq.plugins.jbossas.JBossASDiscoveryComponent] for resource type [JBossAS Server]
      2008-11-14 10:30:25,483 DEBUG [InventoryManager.discovery-1] (rhq.core.pc.plugin.PluginComponentFactory)- Created and cached the discovery component [org.rhq.plugins.jbossas.JBossASDiscoveryComponent] for resource type [JBossAS Server]
      2008-11-14 10:30:25,483 DEBUG [InventoryManager.discovery-1] (org.rhq.core.system.ProcessInfo)- Unexpected error occurred while looking up process info for process with pid [0]. Did the process die? Cause: org.hyperic.sigar.SigarException: Incorrect function.

      .....


      The agent is running on a windows 2003 server platform within a vmware instance.
      The jboss server is running as a windows service.
      Has anyone experienced already this kind of problem ?
      Is there any possibility to configure the agent manually (not using the autodiscovery) by giving all required stuff for communication with the jboss server ?

      Thx in advance for any help.

      Roger.