3 Replies Latest reply on Sep 16, 2009 12:41 AM by mazz

    understadning the discovery command's ouput (a mysql example

    August Simonelli Newbie

      Hi all,

      I've installed jopr 2.3 server and agent on red hat hosts.

      On the agent machine i have mysql running; it's installed from RHN and is:

      mysql-server-5.0.45-7.el5

      I run up my jopr agent and it talks back to the jopr server and looks good.

      When i run the discovery command with the agent it finds a bunch of stuff, much of which shows up in the auto-discovery section of the dashboard on the server.

      But some things don't. For instance discovery shows mysql as:

      MySql.MySql Server: Starting discovery...
      MySql.MySql Server: Process scan detected a server - scan=[ProcessScan: query=[process|basename|match=^mysqld$,process|basename|nomatch|parent=^mysqld$], name=[unix]], process=[process: pid=[31450], name=[/usr/libexec/mysqld], ppid=[31390]]
      MySql.MySql Server: Done.


      I learned in this great post from ian (http://www.jboss.org/index.html?module=bb&op=viewtopic&t=161149) that unless i see a key associated that this is just a query match and not a monitored service.

      So, when this happens how do i know what to do next to get it to associate it and monitor it? In the case referenced above the issues was around it not detecting jboss AS 5.1 and the reasons were very clear.

      But why would i not get mysql detected?

      I'm more interested in how i know why something queried correctly but is not "actually discovered."

      I'm sure this is well-documented and am reading now, but i thought it might worth asking as well (cause i'm lazy and busy and, well, lazy! :-)

      Thanks,

      August