It is an attribute and operation resolver. I agree about abbreviations but I couldn't think of a better name.
Tell me what you think it should be called and it will be so.
maybe we could name it after the algorithm it implements to resolve the names -- so it is then obvious what it does implement in case there are ever other implementations --- TernarySearchTreeResolver? or just call it AttributeOperationResolver. Even that is better cause I dont have to start guessing what the 'AO' stands for :)