3 Replies Latest reply on Sep 13, 2002 2:36 PM by Adrian Brock

    MLet classloader garbaging issue?

    christophe Newbie

      Hi,

      I experimented the MLet service with the JBOSS.2.4.7 (i not sure about the jmx implementation version embedded with) under a linux machine and java SUN JDK1.3.1.
      When a load a mlet file through a registered MLet (a different from the default one), my MBean works fine, but after i unregister it and its loader (MBean MLet) from the MBeanServer, the mlet classloader is still alive. Effectively, when i run the system.gc() through JMP the other instances are freed but none of the static field's objects of my MBean are garbaged that let's me think the classloader is not freed ...
      Of course i checked that my class object wasn't already loaded by the boo classloader.
      Please anybody may tell me if i m wrong or if this behaviour is a bug of the underlying implementation of JMX used in this version.

      Tks,
      Chris L.

        • 1. Re: MLet classloader garbaging issue?
          Juha Lindfors Master

          JBoss 2.4.7 uses Sun's RI implementation.

          • 2. Re: MLet classloader garbaging issue?
            christophe Newbie

            The issue doesn't occur with other implementations such MX4J or JBOSSMX (except that the latter (1.0) seems to read the mlet's codebase properly)
            I quickly try to install mx4j for using with JBOSS...
            - As jboss' main use some sun classes direclty, i cannot remove jmxri.jar
            - If I try to add the mx4j jar into the jboss lib or lib/ext, sun impl is taken systematically ...
            - Finally, i try to add the jar into the JBOSS_CLASSPATH but i obtained:

            java.lang.ClassNotFoundException: org.jboss.configuration.ConfigurationService

            and the same error for all the mbean of the jboss.conf file and of course, the server died.

            So does anybody know how to use MX4J instrumenation level implementation inside the JBOSS2.4.7 server ?

            Chris L.

            • 3. Re: MLet classloader garbaging issue?
              Adrian Brock Master

              You'll have to modify the manifest.mf in run.jar

              You will probably hit some problems due to some
              invokes on attributes in the 2.4 tree.
              That is unless mx4j supports this "bug"

              Regards,
              Adrian