1 Reply Latest reply on Nov 26, 2002 3:00 PM by David Newman

    javax.management.ObjectName InstantiationException in SOAPIn

    David Newman Newbie

      I am testing the SOAPConnector example in Chapter 10 of the JMX book, with the one exception that I have
      deployed the SOAPConnector within JBoss.

      I am able to successfully invoke methods against the RemoteMBeanServer that take no arguments and that
      return either primitive data types or Strings, e.g. getDefaultDomain, or getMBeanCount.

      However, when I invoke methods that contain more complex data types such as ObjectName as an argument, or a return
      value, ex. queryNames, I get the below error. This happens when I execute 'invoker.invoke(mi)' in the
      SOAPInvocationHandler;


      public Object invoke(Object proxy, Method method,
      Object[] args) throws Throwable {

      String methodName = method.getName();

      MethodInvocation mi = new MethodInvocation(method);
      mi.setParams(args);

      return invoker.invoke(mi);

      }


      java.lang.reflect.UndeclaredThrowableException: java.rmi.UnmarshalException: java.io.IOException:
      no argument constructor is missing. java.lang.InstantiationException: javax.management.ObjectName
      at java.lang.reflect.Constructor.newInstance(Native Method)
      at electric.soap.SOAPException.(Unknown Source)
      at electric.soap.SOAPMessage.getSOAPException(Unknown Source)
      at electric.soap.SOAPReference.readResponse(Unknown Source)
      at electric.soap.SOAPReference.invoke(Unknown Source)
      at electric.soap.SOAPReference.invoke(Unknown Source)
      at electric.proxy.handler.Proxy.invoke(Unknown Source)
      at electric.util.proxy.proxy3.InvocationAdaptor.invoke(Unknown Source)
      at $Proxy0.invoke(Unknown Source)
      at com.wellsfargo.ice.management.SOAPInvocationHandler.invoke(SOAPInvocationHandler.java:47)
      at $Proxy1.queryNames(Unknown Source)
      at com.wellsfargo.ice.management.SOAPClient.main(SOAPClient.java:21)
      Exception in thread "main"

      Any ideas on how to fix this?

      Thanks,

      David