2 Replies Latest reply on Dec 9, 2002 6:58 AM by Miro

    Migration of TimerMBean from 2.4.1 to 3.0.3

    Miro Newbie

      In Jboss 2.4.1. I have MBean, which implements TimerMBean. This bean is configured in jboss.jcml and works fine.
      This MBean I want to migrate to the JBOSS 3.0.3. I just copy configuration of this mbean from jboss.jcml to user-service.xml and of course all jars precompiled with new version of jboss.
      When jboss is starting, it is trown runtime error java.lang.NoClassDefFoundError: javax/management/timer/Timer. This class is in jboss-jmx.jar, but when I put this jar into classpath, server doesn't start. Reason: this error:
      10:59:24,375 ERROR [Server] start failed
      java.lang.NoClassDefFoundError: EDU/oswego/cs/dl/util/concurrent/ConcurrentReaderHashMap (I tried this also with jmxri.jar and result is the same)

      What I should do?

        • 1. Re: Migration of TimerMBean from 2.4.1 to 3.0.3
          Adrian Brock Master

          Don't put anything in the classpath.

          Where is the class for your MBean? server/default/lib?

          Try making a sar with user-service.xml replaced
          with jboss-service.xml if you want hot-deploy

          deploy/
          +mymean.sar/
          ++META-INF/jboss-service.xml
          ++my/packagename/mymbean.class

          Regards,
          Adrian

          • 2. Re: Migration of TimerMBean from 2.4.1 to 3.0.3
            Miro Newbie

            Thanks for advise, but it doesn't works.
            I created new EFL.SAR folder, but result is the same. Into EFL.SAR\META_INF\jboss-service.xml was this declaration:
            <?xml version="1.0" encoding="UTF-8"?>


            15



            I tried also put declaration of timer into conf\jboss-service.xml declaration of timer with previous but result still the same. Declaration of Timer:

            or other test:

            Have you some idea, what's wrong?