6 Replies Latest reply on Sep 22, 2003 9:24 AM by Ronald van Kuijk

    web-console not working?

    tomdee Newbie

      JBoss 3.2.1 on Win2K Server SP3.

      I downloaded 3.2.1 and ran JBoss via run.bat -c default

      Then browse to
      http://localhost:8080/web-console

      The screen comes up , right pane has data but left pane is empty and error message shown below in
      the status bar of the browser

      load: org.jboss.console.navtree.AppletBrowser not found

        • 1. Re: web-console not working?
          Scott McLaughlin Newbie

          The web-console applet requires swing (java 1.3+)
          because of this the applet will not load if you are using the Microsoft VM (default in Internet Explorer)

          To fix this problem you will need to install the java runtime on the machine you are connecting to the web-console from. This will install the java-plugin which will allow the web-console applet to load.

          Hope this helps
          Scott

          • 2. Re: web-console not working?
            tomdee Newbie

            thanks. that works great. *Sigh* MS... why is it so difficult with those guys?

            • 3. Re: web-console not working?
              a_ja Newbie

              i have installed jdk1.3(+) .but when i browse to http://localhost:8080/web-console ,The screen comes up , right pane has data but left pane is empty and error message :


              ava.lang.NoClassDefFoundError: com/sun/net/ssl/HttpsURLConnection

              at org.jboss.console.remote.Util.invoke(Util.java:48)

              at org.jboss.console.remote.AppletRemoteMBeanInvoker.invoke(AppletRemoteMBeanInvoker.java:50)

              at org.jboss.console.navtree.ConsoleTreeModel.loadTree(ConsoleTreeModel.java:104)

              at org.jboss.console.navtree.ConsoleTreeModel.(ConsoleTreeModel.java:59)

              at org.jboss.console.navtree.AdminTreeBrowser.(AdminTreeBrowser.java:63)

              at org.jboss.console.navtree.AppletBrowser.start(AppletBrowser.java:51)

              at sun.applet.AppletPanel.run(Unknown Source)

              at java.lang.Thread.run(Unknown Source)

              • 4. Re: web-console not working?
                rrobins Newbie

                The java.lang.NoClassDefFoundError: com/sun/net/ssl/HttpsURLConnection

                Is usually due to jsse.jar not being found in the classpath. jsse.jar comes as part of j2se 1.4 or as a separate download from java.sun.com

                However, I'm running jboss 4 and have the same problem after having included jsse.jar to the classpath. Does anyone have any ideas? This is starting to defy logic.

                • 5. Re: web-console not working?
                  a_ja Newbie

                  up

                  • 6. Re: web-console not working?
                    Ronald van Kuijk Newbie

                    Try adding it to the classpath of the browser! (include it in the jre/lib/ext)

                    hth