1 Reply Latest reply on Apr 9, 2004 10:06 AM by Scott Stark

    SARs in EARs: Is this still possible?

    Peter Luttrell Newbie

      In JBoss3.2.1, i was able to deploy my EAR that contained a SAR. The SAR was in the root of the EAR file and i specified the SAR file as a item in my application.xml. This worked perfectly.

      However in JBoss3.2.3, this identical configuration when deployed results in the following VM Error, and then JBoss usually restarts itself or oddly, continues.

      Unexpected Signal : EXCEPTION_ACCESS_VIOLATION (0xc0000005) occurred at PC=0x807D51E
      Function=[Unknown.]
      Library=C:\dev\jdks\j2sdk1.4.2_04\jre\bin\server\jvm.dll

      NOTE: We are unable to locate the function name symbol for the error
      just occurred. Please refer to release documentation for possible
      reason and solutions.

      So my questions is: Should this still work? Should it have ever worked?

      If this should work, any ideas on why i'm getting this vm error? It happens on multiple machines, one with jdk1.4.2_04 and another with jdk1.4.2, both on WindowsXP.

      thanks.
      .peter