5 Replies Latest reply on Jul 20, 2004 8:41 AM by cistechselvin

    Scheduler problem

    louis_ja Newbie

      Hello,

      I have a strange problem with a schedulable job in a JBoss 3.2.3 server.

      I have a simple schedulable task, let's say I just want to log something every day.

      I have multiple JBoss instances on different PCs, most are Win2K, one is Win2k server. All the JBoss instances are coming from the same archive and are thus equivalent.

      On the Win2k PCs, no problem, everything works fine, at the time I want: NOW or any other date.
      I then see my output at the scheduled time.

      The probelm happens on the Win2K server one, where my schedule never starts except if I say NOW instead of any other date.
      There is nothing in the logs regarding my scheduler except that it has been deployed.

      Has anyone encountered this before ?
      The only difference I see for the moment is the Win2k flavor ... but how could it impact the JBoss scheduler ??

      Here is the jboss-service.xml file:

      true

      test.MySchedulableTest
      26/04/2004 10:45 am
      86400000
      <!-- every day -->
      -1


      Thanks for your attention,
      Louis

        • 1. Re: Scheduler problem
          louis_ja Newbie

          Hum,

          screwed up my jboss-service.xml inclusion ...

          here it is again:

          <mbean code="org.jboss.varia.scheduler.Scheduler"
           name=":service=Scheduler,schedule=MyScheduler">
           <attribute name="StartAtStartup">true</attribute>
           <attribute name="SchedulableClass">test.MySchedulerClass</attribute>
           <attribute name="InitialStartDate">24/06/2004 10:45 am</attribute>
           <attribute name="SchedulePeriod">86400000</attribute>
           <attribute name="InitialRepetitions">-1</attribute>
           </mbean>


          • 2. Re: Scheduler problem
            Darran Lofthouse Master

            Have you checked (and double checked) the regional settings and date and time on the server machine?

            • 3. Re: Scheduler problem
              louis_ja Newbie

              Double checking was the point :-)

              Looks like it is linked to Locale / Date format settings.

              However, behaviour is a little confusing ... but that's another matter.

              Thanks for the tip darranl, I had checked, but not double checked.

              Louis

              • 4. Re: Scheduler problem
                louis_ja Newbie

                Hello,

                I'm replying here, because my problem is not yet completly solved.

                Since last time, I managed to make the scheduler start with the correct settings of Locale and date format.

                However, using French(Belgium) as my locale, with daylight savings activated (moves us from GMT+1 to GMT+2 during the summer), and with a scheduled time at 0:01 (am) my task starts at 1:01 (am).

                Any idea why it would do that ?
                Is there a limitation with scheduling stuff just after midnight ?

                Thanks for your attention,
                Louis

                • 5. Re: Scheduler problem
                  cistechselvin Newbie

                  I want to schedule an application thorugh jboss and kindly me guide me to carry forward