1 Reply Latest reply on Dec 9, 2005 3:56 PM by Matt Parker

    MBean Started Twice

    Matt Parker Newbie

      When I deploy a MBean that is tied to the Scheduler MBean, its started twice in JBoss, and both processes run concurrently causing all kinds of problems. Below is the deployment descriptor. I'm using 4.0.3 SP 1. Would it be running twice since there are two schedulers running on the system?

      <!-- The SAR META-INF/jboss-service.xml descriptor -->
      
      <server>
      
       <!-- JBoss Scheduler Service -->
       <mbean code="org.jboss.varia.scheduler.Scheduler" name="akm:service=AKMDocumentIndexScheduler">
      
       <classpath>xerces-impl.jar,xml-apis.jar,xml-parser-apis.jar</classpath>
       <classpath>classifier4J-0.6.jar,lucene-1.4.3.jar</classpath>
       <classpath>lucene-parser.jar,nekohtml.jar,nekohtmlXni.jar</classpath>
      
       <attribute name="StartAtStartup">true</attribute>
       <attribute name="SchedulableMBean">akm:service=AKMDocumentIndexService</attribute>
       <attribute name="SchedulableMBeanMethod">indexDocuments</attribute>
      
       <!-- Run every hour -->
       <attribute name="InitialStartDate">NOW</attribute>
       <attribute name="SchedulePeriod">60000</attribute>
       <attribute name="InitialRepetitions">-1</attribute>
       <!--
       <depends>jboss:service=AKMDocumentIndexService</depends>
       -->
       </mbean>
      
       <!-- Lucene Parser -->
       <mbean code="com.anser.service.web.lucene.Index" name="akm:service=AKMDocumentIndexService">
       <attribute name="DocumentRoot">C:\AKM\Current</attribute>
       <attribute name="IndexRoot">C:\AKM\Index</attribute>
       <attribute name="TextArchive">C:\AKM\TextArchive</attribute>
       <attribute name="ConfigRoot">C:\AKM\Lucene</attribute>
       </mbean>
      
      </server>
      


      Would anyone have an idea as to why this is happening? TIA.