1 Reply Latest reply on May 18, 2006 3:33 AM by Dimitris Andreadis

    jmx remote bind address

    Sean McEligot Newbie

      I'm starting jmx with the following jmx options:

      JAVA_OPTS="-Djavax.management.builder.initial=org.jboss.mx.server.MBeanServerBuilderImpl"
      JAVA_OPTS="$JAVA_OPTS -Djboss.platform.mbeanserver"
      JAVA_OPTS="$JAVA_OPTS -Dcom.sun.management.jmxremote.port=12345"
      JAVA_OPTS="$JAVA_OPTS -Dcom.sun.management.jmxremote.authenticate=true"
      JAVA_OPTS="$JAVA_OPTS -Dcom.sun.management.jmxremote.password.file=/path/to/jmxusers.properties"
      JAVA_OPTS="$JAVA_OPTS -Dcom.sun.management.jmxremote.access.file=/path/to/jmxusers.properties"
      JAVA_OPTS="$JAVA_OPTS -Dcom.sun.management.jmxremote.ssl=false"
      JAVA_OPTS="$JAVA_OPTS -Djboss.platform.mbeanserver"
      export JAVA_OPTS
      $JBOSS_HOME/bin/run.sh -b myhostname -c myservername


      I want to bind the jmxreport port 12345 to a specific hostname. I filed a bug report with Sun on this since it doesn't seem to be a JBoss issue.
      http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6425769
      Since there is a workaround mentioned, I'm thinking of filing a RFE with JBoss, but I want to ask here first.

      I tried setting java.rmi.server.hostname, but that didn't help.