2 Replies Latest reply on Aug 23, 2007 12:26 PM by Sen

    Can Not run "twiddle". Bug of 4.0.5?

    Sen Newbie

      Hello everyone,

      I am trying to learn how to use JBoss's JMX funtionalities to monitor my application. In the "JBoss Application Server Guide", it says to call "bin\twiddle" to get access to the JMX. However, once I run "twiddle", there will be an exception:

      Exception in thread "main" java.lang.NoClassDefFoundError: org/jboss/util/Nested
      Exception
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
      ...

      My JBoss version is: 4.0.5.GA
      JDK is: 1.5.0.12

      In http://jira.jboss.com/jira/browse/JBAS-3382?page=all, it talks about this problem with version 5.0.0. It says add "client/jboss-common.jar" to classpath.

      First of all, in 4.0.5, "jboss-common.jar" is in "lib" not "client". So I tried to add "lib/jboss-common.jar" to classpath. But still can not solve the problem.

      Does expert know how this problem can be solved? Thank you very much