12 Replies Latest reply on Sep 22, 2009 6:45 PM by Ramesh Reddy

    Errors opening with Model Editor in Eclipse 3.5 M7

    Ben Truitt Newbie

      Hi -
      I am experiencing a couple of errors when I open an "xmi" model file by right-clicking in the model explorer view and choosing "open with", "model editor."

      I get two separate error dialog boxes, then the Diagram editor appears with a blank canvas and no buttons in the left-side of the pane.

      The error messages are:

      Error attempting to load a Model Object Editor Page plugin

      ID = com.metamatrix.modeler.webservice.ui.editor.OperationObjectEditorPage


      Error attempting to load a Model Object Editor Page plugin

      ID = com.metamatrix.modeler.transformation.ui.editors.TransformationObjectEditorPage


      I am using the most recent SNAPSHOT version of the Designer on Eclipse Version: 3.5.0 M7 (Build id: I20090430-2300), java.runtime.version=1.6.0_07-b06-153, on mac os x version 10.5.6.

      Please let me know if you would prefer for me to log this as a Jira issue, or report this type of issue in some other way.

      Thanks!
      Ben Truitt

        • 1. Re: Errors opening with Model Editor in Eclipse 3.5 M7
          Barry LaFond Master

          Ben,

          Thx for test-driving Designer on Mac. Per our Download/Install instructions, only Eclipse's 3.5+ versions would have the necessary Java, 64-bit combination. However, we have not tested with that installation, so you are paving the way.

          Please log a JIRA and be sure to include all of your configuration info from your post.

          The failure of the Diagram Editor (toolbars) to fully display plus errors in instantiation of two sub-editors are probably all connected. Can you check your log files and attach them if they contain any additional info? A stack trace would go a long way.

          Thx

          Barry LaFond
          Teiid Designer Project Lead

          • 2. Re: Errors opening with Model Editor in Eclipse 3.5 M7
            Ben Truitt Newbie

            Hi Barry -
            Yes, I should have pointed out that I am using bleeding edge builds so that I can get this working on a Mac.

            My team of 4 developers all have macs and we are very interested in getting up and running with Teiid as quickly as possible on our technology stack.

            I'll be happy to help as much as possible in diagnosing issues.

            I've created the following Jira issue to track this bug:
            https://jira.jboss.org/jira/browse/TEIID-588

            Please let me know if there is anything more I can do to help get this resolved.

            Thanks!
            Ben Truitt

            • 3. Re: Errors opening with Model Editor in Eclipse 3.5 M7
              Barry LaFond Master

              Ben,

              I tried installing Eclipse 3.5 M7 on Linux then tried installing Designer ( our latest SNAPSHOT ) as an update site archive. I can't get it to finish. Problems with UML2 versions.

              So I'm not sure how you got it to install in the first place. Can you describe your steps?

              Barry

              • 4. Re: Errors opening with Model Editor in Eclipse 3.5 M7
                Ben Truitt Newbie

                Hi Barry -
                Yeah I had some trouble getting the pre-requisite plugins installed. It didn't record the exact steps that I used, but I ended up downloading local zip archives for each of the plugin versions specified on this page:

                http://jboss.org/teiiddesigner/downloads.html

                Once those were installed succesfully, I was able to install the snapshot.

                I know that is a bit vague, so if you need more detail, let me know.

                -Ben

                • 5. Re: Errors opening with Model Editor in Eclipse 3.5 M7
                  John Verhaeg Newbie

                  Ben,

                  That may be part of the problem. If you install Eclipse 3.5, then the requirements on the project page no longer apply. You really need to install the versions of EMF, UML2, XSD, and GEF that work against 3.5 (e.g., EMF 3.0.0, etc.).

                  • 6. Re: Errors opening with Model Editor in Eclipse 3.5 M7
                    Ben Truitt Newbie

                    Gotcha. I can try a fresh install in that case. I may not get to this until later today or tomorrow. I'll let you know what I find.

                    -Ben

                    • 7. Re: Errors opening with Model Editor in Eclipse 3.5 M7
                      Ben Truitt Newbie

                      Hi,
                      Just to clarify JPAV's comment, it looks like the latest EMF version for 3.5 eclipse is 2.5. I get this from the table on this page:
                      http://www.eclipse.org/modeling/emf/downloads/?project=emf

                      So rather than EMF 3.0.0, it would be EMF 2.5.0. Let me know if you disagree.

                      -Ben

                      • 8. Re: Errors opening with Model Editor in Eclipse 3.5 M7
                        John Verhaeg Newbie

                        Ben,

                        Sorry, you are correct. It's UML2 3.0.0 that matches up with Eclipse 3.5.

                        • 9. Re: Errors opening with Model Editor in Eclipse 3.5 M7
                          Ben Truitt Newbie

                          Okay - so now i've installed the dependent plugins on a fresh Ecilpse 3.5 installation. They all installed fine.

                          Now I'm trying to install the designer, and it is failing (this is why I reverted to an older version of UML2 in my first attempt). Here is the error message:

                          Cannot complete the install because one or more required items could not be found.
                          Software being installed: org.teiid.designer.feature.group 6.0.0.v20090427_SNAPSHOT
                          Missing requirement: org.teiid.designer.feature.group 6.0.0.v20090427_SNAPSHOT requires 'org.eclipse.uml2.feature.group [2.2.0,3.0.0)' but it could not be found


                          So the issue seems to be that the designer plugin expects UML2 up to (but not including) UML2 3.0.0. However 3.0.0 is the version that works with Eclipse 3.5.

                          Yesterday when I originally ran into this I tried hacking an XML file in the designer plugin to increase that upper limit, and that did not work (no real surprise there).

                          So my guess is that I'll need to ask you guys to update the designer to work with the 3.0.0 version of UML2. Sound right to you?

                          -Ben

                          • 10. Re: Errors opening with Model Editor in Eclipse 3.5 M7
                            John Verhaeg Newbie

                            Ben,

                            Unfortunately, I believe you are correct. You may have to wait until we really support this to install it from the update site archive. However, you might be able to accomplish this by just extracting the archive directly into your Eclipse installation and modifying versions of the dependencies specified in the Designer's feature.xml (in the org.teiid.designer folder under the feature folder). Then there's always "the hard way", doing you own build after checking the project out from SVN. You'd then:

                            1) Point your target platform at your installation that already contains the 3.5 version of Eclipse and related necessary projects (EMF, etc.).

                            2) Modify the versions of the required projects in the feature.xml within the org.teiid.designer-feature project.

                            There's still no guarantee that the application will run normally, but you may get far enough for it to be usable.

                            • 11. Re: Errors opening with Model Editor in Eclipse 3.5 M7
                              Curt Newbie

                              This appears to be working now. I encountered the same um2.feature.group issue with an install of 64bit cocoa 3.5 release. I edited the content.xml entry in the teiid-designer archive to 3.1.0 from 3.0.0. This bypassed that error and installed as normal.

                              The perspective comes up and I have not received any errors yet. Will try it out and see if there are any problems.

                              Thanks,
                              Curt

                              • 12. Re: Errors opening with Model Editor in Eclipse 3.5 M7
                                Ramesh Reddy Master

                                Here are the instructions to install Teiid Designer in Eclipse 3.5 version. This summarizes all the messages above.

                                1) Download Eclipse 3.5 (galileo ). I installed JEE version, but you can use classic any one you like. Install it. http://www.eclipse.org/downloads/

                                2) Download and Install 2.5 version of EMF & XSD. Download here. http://www.eclipse.org/modeling/download.php?file=/modeling/emf/emf/downloads/drops/2.5.0/R200906151043/emf-xsd-Update-2.5.0.zip

                                3) Download and install 3.0.0 version of UML2 plug-ins. Download here. http://www.eclipse.org/modeling/download.php?file=/modeling/mdt/uml2/downloads/drops/3.0.0/R200906151558/mdt-uml2-Update-3.0.0.zip

                                4) Download and install 3.5 version of GEF plug-in. Download here. http://www.eclipse.org/gef/download.php?file=/tools/gef/downloads/drops/3.5.0/R200906221200/GEF-Update-3.5.0.zip

                                5) Now, Download but do not install Teiid Designer archive.

                                6) Explode Teiid Designer zip archive to temp location.

                                7) In the root directory find and edit "content.xml" file, and find the line that says

                                <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.uml2.feature.group' range='[2.2.0,3.0.0)'/>
                                


                                and modify it to say

                                <required namespace='org.eclipse.equinox.p2.iu' name='org.eclipse.uml2.feature.group' range='[2.2.0,3.1.0)'/>
                                


                                save and close. (see the version changed to 3.0.0 to 3.1.0. Looks like even though we want to use the 3.0.0, the reading logic of this file is not inclusive of the end target versions, so it is always looking for >2.2.0 and < 3.0.0, where it should be <=3.0.0, trick it by saying 3.1.0, now 3.0.0 UML2 plug-in gets picked up)

                                8) Still in the "Teiid Designer" exploded location, find "features" directory. Find "org.teiid.designer_xxxx.jar" file, open this with your zip utilities, and edit "features.xml" file inside it and find and update the versions of UML2, GEF, XSD, EMF as below

                                 <requires>
                                 <import feature="org.eclipse.emf" version="2.5.0"/>
                                 <import feature="org.eclipse.gef" version="3.5.0"/>
                                 <import feature="org.eclipse.platform" version="3.5"/>
                                 <import feature="org.eclipse.uml2" version="3.0.0"/>
                                 <import feature="org.eclipse.xsd" version="2.5.0"/>
                                 </requires>
                                


                                save and close, make sure that the jar file containing this file is updated correctly. (you may need to explode this jar file to edit the feature.xml file)

                                9) Now bundle the temp directory created into a zip archive using any of the zip utilities you have.

                                10) Now install the archive created in step 9, into Eclipse 3.5 using the installation instructions specified on the web site. (note that on the install dialog box to un check the group items by category to see the Teiid Designer option to show up and accept the license and install away.

                                Enjoy the Teiid Designer in Eclipse 3.5. I do not know you, but I can not run Eclipse 3.4.1 due to some Firefox/xml-runner bug on my Fedora 11. Hopefully this helps some one out there.

                                Thanks

                                Ramesh..