11 Replies Latest reply on Nov 14, 2003 8:46 PM by chino8

    Jboss in JBuilder

    Anand B N Newbie

      I know there's some document that walks you thru the procedure but someone I'm not able to configure a standalone JBoss 2.4.3 on JBuilder.

      Is this possible.If someone is done this plese let me know.

        • 1. Re: Jboss in JBuilder
          Brent Thompson Newbie

          I've done it. Let me know what you are having problems with.

          • 2. Re: Jboss in JBuilder
            scott lauder Newbie

            am having problems with auto-deployer in builder...
            [AutoDeployer] Starting

            [AutoDeployer] Watching D:\$JBOSS_TOMCAT_HOME\jboss\deploy

            [AutoDeployer] Watching D:\$JBOSS_TOMCAT_HOME\jboss\deploy\lib

            [Default] java.lang.NullPointerException:

            [Default] at org.jboss.ejb.AutoDeployer.run(AutoDeployer.java:144)

            [Default] at org.jboss.ejb.AutoDeployer.startService(AutoDeployer.java:353)

            [Default] at org.jboss.util.ServiceMBeanSupport.start(ServiceMBeanSupport.java:107)

            [Default] at java.lang.reflect.Method.invoke(Native Method)

            [Default] at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1628)

            [Default] at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1523)

            [Default] at org.jboss.configuration.ConfigurationService$ServiceProxy.invoke(ConfigurationService.java:836)

            [Default] at $Proxy0.start(Unknown Source)

            [Default] at org.jboss.util.ServiceControl.start(ServiceControl.java:81)

            [Default] at java.lang.reflect.Method.invoke(Native Method)

            [Default] at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1628)

            [AutoDeployer] Started

            • 3. Re: Jboss in JBuilder
              Stephen White Newbie

              Do you manage this and how??

              • 4. Re: Jboss in JBuilder -breakpoint not stopping
                scott lauder Newbie

                I am having problems with break points in my code.
                In builder I have Jboss running with my someejb.jar deployed. That jar was all compiled with debugging on.
                Jboss tells me its deployed ok.
                Also in builder, in another project I have client code which creates the ejb bean and calls some method on it. I see in the jboss output window my methods gets called but the breakpoints are not beening stopped at. I do have the src to someejb.jar in the scr path in jbuilder in the jboss project. Please anyone can reach me direct at slauder@jmm.com or by replying to this thread. Thanks in advance.

                • 5. Re: Jboss in JBuilder
                  Chris Harris Newbie

                  Sounds like you are debugging the client, not the server. I've had a lot of success debugging JBoss remotely through JBuilder but I'm using the Enterprise edition. This is the best solution if you have JB6E.

                  Running JBoss inside JBuilder is also possible (as a project itself) but requires setting up a huge classpath in the Project...Required Libraries (basically all the lib/*.jar and lib/ext/*.jar files in the JBoss distro). You can set up a Run Configuration in JBuilder to invoke JBoss from inside your project.

                  c

                  • 6. Re: Jboss in JBuilder
                    Brent Thompson Newbie

                    JBoss Setup Wizard, id#17446 at codecentral. This will setup jboss to run from within JBuilder5 and 6 personal/enterprise edition.

                    • 7. Re: Jboss in JBuilder
                      Ole Laurisch Newbie

                      Codecentral id#17446 ???
                      Can yoe explain a Dummy what you mean by that?

                      What is Codecentral? How do I go there?

                      Please help me! Thanks!

                      • 8. Re: Jboss in JBuilder
                        Brent Thompson Newbie

                        no problem, here is the link
                        Download the zip file and follow the instructions in the
                        html document. Codecentral is a repository for jbuilder plugins using borland's opentools api.

                        http://radweb.borland.com/codecentral/ccweb.exe/listing?id=17446

                        • 9. Re: Jboss in JBuilder
                          Ole Laurisch Newbie

                          Yeah, thanks!
                          It works!

                          I have successfully integrated JBoss! *smile*

                          But there's one question left - I know ... not really the right thread, but I don't find the right one again.

                          Yesterday I read something about the price for JBuilder. I know that you have to pay $2999 for the Enterprise Edition 6. But I think I remember that there was something about a regular fee - every half year I think. Do you know anything about that?

                          • 10. Re: Jboss in JBuilder
                            chino8 Newbie

                            Hi. The opentool from codecentral works fine and I managed to create session and entity beans and deploy them.
                            But the problem is when I try to create a jsp page under a web application, somehow it doesn't let me compile it nor run it. I think there's got some extra setup required for configuring tomcat.
                            Anybody been through this???
                            Thanks!!

                            • 11. Re: Jboss in JBuilder
                              chino8 Newbie

                              Hi. The opentool from codecentral works fine and I managed to create session and entity beans and deploy them.
                              But the problem is when I try to create a jsp page under a web application, somehow it doesn't let me compile it nor run it. I think there's got some extra setup required for configuring tomcat.
                              Anybody been through this???
                              I'm using JBuilder 9 and JBoss 3.2.2
                              Thanks!!