10 Replies Latest reply on Dec 17, 2001 6:45 PM by S. N. Pole

    Problem when start JBoss

    Alan Alves de Oliveira Newbie

      Good Afternoon !

      We have a problem when beginning JBOSS, it presents syntax mistake in the following lines:

      set JAXP=-Djavax.xml.parsers.DocumentBuilderFactory=org.apache.crimson.jaxp.DocumentBuilderFactoryImpl

      set JAXP=%JAXP% -Djavax.xml.parsers.SAXParserFactory=org.apache.crimson.jaxp.SAXParserFactoryImpl


      If could indicate me which is the problems in those lines thank. Thank you very much.

      JBOSS 2.4.4 TomCat 4.0.1 Beta
      Windows ME


      Alan Alves de Oliveira
      alan@networkinformatica.com.br
      Network Informatica Ltda.

        • 1. Re: Problem when start JBoss
          Adrian Brock Master

          The Soap Weirdness Thread has reported a similar problem.

          Regards,
          Adrian

          • 2. Re: Problem when start JBoss - not work on Win98/ME?
            S. N. Pole Newbie

            I met the same problem when I installed JBoss on Win98 with JDK Standard Edition 1.3.1. But it works well on Solaris.

            On Win98, when I tried run.bat, it said something like "command or file name not found". Then I tried each line of that file. It failed with "set JAXP=...", syntax error.

            Does JBoss not work on Win98/ME?

            Hope someone could help me.

            Thanks.

            S. N. Pole

            • 3. Re: Problem when start JBoss - not work on Win98/ME?
              Alan Lewis Newbie

              JBoss works on Win98/ME, you sometimes just have to hack the batch file a little bit...

              To get around the problem you are seeing, do the following to run.bat:

              1. REM out lines 14 and 15
              2. Change line 18 to the following (all on one line of course):

              java -Djavax.xml.parsers.DocumentBuilderFactory=org.apache.crimson.jaxp.DocumentBuilderFactoryImpl -Djavax.xml.parsers.SAXParserFactory=org.apache.crimson.jaxp.SAXParserFactoryImpl -classpath "%JBOSS_CLASSPATH%" org.jboss.Main %1 %2 %3 %4 %5 %6 %7 %8 %9


              I think that the error under Win98/ME is caused by trying to set an environment variable to a value that includes an equals sign.

              Please let me know if this fixes your problem!

              • 4. Re: Problem when start JBoss
                S. N. Pole Newbie

                Putting -D...=... into java command makes it too long to execute on DOS. Is there a way to extend the length of DOS command or put _D...=... into two environmental variables, such as %A%=%B%?

                Thanks.

                S. N. Pole

                • 5. Re: Problem when start JBoss
                  Alan Lewis Newbie

                  You need to give the DOS box more memory. Right click on the title bar of the DOS box, click properties, click the Memory tab, and change Initial Environment to 4096. That should do it... It does for me on the Win98 machine I use at home.

                  • 6. Re: Problem when start JBoss
                    S. N. Pole Newbie

                    Thanks for your reply.

                    But I tested on several other Win98s. Extending the initial memory or enlarging memory space seems not solve the problem. I changed the command to something like this:
                    java %A%=%B% %C%=%D% -classpath ...
                    It still doesn't work. When I run the script line by line, "syntax error" doesn't show up. But it said, "java.io.ioexception, jboss.properties missing
                    at org.jboss.main.main(main.java:74)"

                    I am not familiar with these manipulating these DOS scripts. I was wondering if the other version has the same run.bat.

                    S. N. Pole

                    • 7. Re: Problem when start JBoss
                      Fusayuki Minamoto Apprentice

                      Can you see the run.bat as a normal Windows file with notepad.exe?
                      If not, it may be a Unix file.

                      To execute run.bat on Windows 98 I had a problem with JBoss 2.4.3.
                      Finally I resolved it by changing every line ends of the run.bat.
                      But I found the run.bat in JBoss-2.4.3_Tomcat-3.2.3.zip was a normal Windows file.

                      Miki

                      • 8. Re: Problem when start JBoss
                        S. N. Pole Newbie

                        Thanks Miki. It works and started 46 serviecs, but there are two syntax errors at the beginning of the execution. I am going to look for the cause of the two errors.

                        S. N. Pole

                        • 9. Re: Problem when start JBoss
                          Frank Griffin Novice

                          This is a Win98 problem, and I've seen it, though I haven't researched it exhaustively. The problem may indeed be the equals sign in the assignment value, or it may be the embedded blanks. In any case, the two syntax errors come from the SET statements in run.bat. I put everything on the command line and it worked on an unmodified Win98SE without length errors.

                          If you're REALLY doing this under DOS, I don't know what to tell you. Did you remove the SETs as well as including the definitions on the command line ?

                          • 10. 360284
                            S. N. Pole Newbie

                            Thanks for all your replies. Now it works correctly by editing the run.bat:
                            1. change the format to Window
                            2. move the two SETs that have equal sign into java command directly.
                            No change to any Window variables.

                            The strange thing is I cannot put that java command on the command line as it is too long, but it works well when it is in the batch file. I enlarged buffer, but that didn't help.

                            Anyway, now it works well and I can try sth. more. Thanks.

                            S. N. Pole