4 Replies Latest reply on Dec 18, 2001 5:00 AM by Ahmet PATA

    Jboss Generic Problem: I can not run after install

    Ahmet PATA Newbie

      Hi,
      I have downloaded Jboss+Jetty 2.4.3, and I always get the exception regardless of the version of JBoss (2.4.3, 2.1 ...). I have SDK 1.3.1. I think I am doing something wrong. Thanks.

      ---EXCEPTION REPORT HERE------

      javax.management.ServiceNotFoundException: Problems while parsing URL file:/D:/j
      ava/JBoss-2.4.3_Jetty-3.1.3-1/jboss/conf/default/jboss.conf
      at javax.management.loading.MLet.getMBeansFromURL(MLet.java:410)
      at javax.management.loading.MLet.getMBeansFromURL(MLet.java:369)
      at org.jboss.Main.(Main.java:193)
      at org.jboss.Main$1.run(Main.java:127)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.jboss.Main.main(Main.java:123)
      JBoss 2.4.3 Started in 0m:0s
      Press any key to continue . . .

        • 1. Re: Jboss Generic Problem: I can not run after install
          Adrian Brock Master

          Hi,

          Can you post

          d:\java\JBoss-2.4.3_Jetty-3.1.3-1\jboss\conf\default\jboss.conf

          It should contain something like

          <!-- ===================================================================== -->
          <!-- -->
          <!-- JBoss JMX Boot-strap Configuration -->
          <!-- -->
          <!-- ===================================================================== -->




          etc....

          Regards,
          Adrian

          • 2. Re: Jboss Generic Problem: I can not run after install
            Ahmet PATA Newbie

            Hello, I am pasting the file, it is original one that I get after unzipping the package.
            Thanks.

            ---------------------------------------------------
            <!-- ===================================================================== -->
            <!-- -->
            <!-- JBoss JMX Boot-strap Configuration -->
            <!-- -->
            <!-- ===================================================================== -->




            <!-- The log4j based logging service based on the conf log4j.properties file -->



            <!-- The log dir needs to be in the classpath to allow location of log.properties -->



            <!-- Place the config directory in the classpath -->
























            • 3. Re: Jboss Generic Problem: I can not run after install
              Adrian Brock Master

              Hi,

              Your file looks the same as mine, so that's not the problem.

              I assume it's not an authority problem, otherwise you wouldn't be able to get as far as you got.

              The error you are getting comes from Sun's JMX reference implementation.
              But this works for thousands of other people and hasn't changed since August 2000.

              I know JMX doesn't require JAXP so it must have its own xml parser built in, no configuration problem there?

              You are running on windows, so this shouldn't be a character set problem.
              Forget I even mentioned that nightmare.

              Why can't it parse the file???

              Are there any errors/warnings before the useless "Problems while parsing URL..." error message?

              There is something you can try. Sun's JMX provides a
              mechanism to trace what it is doing.

              In the bin directory edit run.bat
              Find the line that begins "java" nearly at the bottom and change it to:

              java %JAXP% -DLEVEL_TRACE -DINFO_MLET -DTRACE_OUTPUT=trace.txt -classpath "%JBOSS_CLASSPATH%" org.jboss.Main %1 %2 %3 %4 %5 %6 %7 %8 %9

              This should produce a file "trace.txt" when you run JBoss.
              I've never used this myself but it might have some useful information.

              Regards,
              Adrian

              • 4. Re: Jboss Generic Problem: I can not run after install
                Ahmet PATA Newbie

                Hello,

                Adrian, thanks for the help, although trace.txt file did not help much, your previous message guided me to solve the problem: It was a regional problem, my regional settings is Turkish, and everything is working when I change it to English.
                When I look to trace.txt file, it says:
                (MLet getMBeansFromURL) <URL = file:/D:/java/JBoss-2.4.3_Jetty-3.1.3-1/jboss/conf/jetty/jboss.conf>
                (MLetParser parse) tag requires archive parameter.
                (MLet getMBeansFromURL) Problems while parsing URL file:/D:/java/JBoss-2.4.3_Jetty-3.1.3-1/jboss/conf/jetty/jboss.conf
                which I think not related with the problem, perhaps it's a bug? I am not sure.

                I don't have any problem reading any character coded text, but something forces me to use English regional settings which does not mean any harm to my works. Thanks for the help.

                PATA