12 Replies Latest reply on May 7, 2002 6:05 PM by Jim Rand

    JBoss-2.4.4_Tomcat-4.0.1-beta just HANGS

    Bikal Gurung Newbie

      Hi,

      I am having problem starting up the JBoss server. Apparently, it hangs when trying to load the Hypersonic database MBean on port 1476(the default). It gives me and SQLException: The Database is already in use by another process. However, I have no other process/service in my computer using port 1476 before the JBoss server starts. But when I start JBoss and do 'netstat' I can see two instances of 127.0.0.1:1476. From what I can deduce the JBoss is trying to load the Hypersonic DB two times, but the MBean is defined just once in jboss.jcml. The jboss just hangs when trying to load another MBean after failing to load the Hypersonic DB. Can anyone help. Thanks in advance.

        • 1. Re: JBoss-2.4.4_Tomcat-4.0.1-beta just HANGS
          Saeid Zoonematkermani Newbie

          I seem to be having the same problem. But I also get it some times with JBoss-2.4.3_Tomcat3.2.3. It seems to happen after some kind of error has happened, For instance, if you try to go to a page that does not exist and you would get a 404 error.

          Then, if If I shutdown JBoss and try to restart, it would just hangs:
          [HypersonicDatabase] Database started
          [HypersonicDatabase] Started
          [XADataSourceLoader] Starting
          [DefaultDS] XA Connection pool DefaultDS bound to java:/DefaultDS

          Any help would be greatly appreciated.

          • 2. Re: JBoss-2.4.4_Tomcat-4.0.1-beta just HANGS
            M. Flood Newbie

            I am having a similar problem, but running JBoss-2.4.4_Tomcat-4.0.1 (NOT the beta version). I'm testing under Windows ME. There are no errors that precede this; I simply do a "run_with_catalina", and find that it hangs here:

            ...
            [INFO,JdbcProvider] Started
            [INFO,HypersonicDatabase] Starting
            [INFO,Default] Server 1.6 is running
            [INFO,Default] Press [Ctrl]+[C] to abort
            [INFO,HypersonicDatabase] Database started
            [INFO,HypersonicDatabase] Started
            [INFO,DefaultDS] Starting
            [INFO,DefaultDS] XA Connection pool DefaultDS bound to java:/DefaultDS

            Any help will be greatly appreciated. Thanks.

            • 3. Re: JBoss-2.4.4_Tomcat-4.0.1-beta just HANGS
              Jorge Newbie

              Same in my case on a Linux box.

              • 4. Re: JBoss-2.4.4_Tomcat-4.0.1-beta just HANGS
                Alex Abbas Newbie

                Same for me on Mac OS X... both Tomcat 3.2.3 and 4.0.1, it just stops at "[INFO,DefaultDS] XA Connection pool DefaultDS bound to java:/DefaultDS". Somebody please help!

                Alex

                • 5. Re: JBoss-2.4.4_Tomcat-4.0.1-beta just HANGS
                  Jonathan Tan Newbie

                  Heh you guys!
                  Just want to check which JVM/JDK you have installed I also have similar problems but when I run using "run_with_catalina" it seems to work. I run JDK 1.3.1.


                  Cheers
                  Jonathan

                  • 6. Re: JBoss-2.4.4_Tomcat-4.0.1-beta just HANGS
                    Ed Ludke Newbie

                    Okies . . . seeing alot of people with the same problem but not seeing any answers . . . .

                    I don't know if this is true for all of the others, but what I'm seeing, is that it works fine the first time in; it only has this problem after I stop the server (<ctrl-c> in the command window where I started it) and try to restart it right back up. I've found that I can suffer along if I just wait about 5 or 10 mins between stopping and starting. I've watched my processes to no avail, so I've no idea what might still be running - else I'd kill it!

                    Please, if anyone can shed some light on how to fix this, it would be much appreciated!

                    Thanks,
                    Ed Ludke

                    • 7. Re: JBoss-2.4.4_Tomcat-4.0.1-beta just HANGS
                      Ed Ludke Newbie

                      Got some more details regarding this problem (no fix yet, just more info):

                      Compared the logs between a clean starup and a startup that hangs. Here's the point where the trouble begins:

                      Log from hung instance:

                      [INFO,HypersonicDatabase] Starting
                      [INFO,Default] Server.run/init: java.net.BindException: Address in use: JVM_Bind

                      [INFO,HypersonicDatabase] Database started
                      [INFO,HypersonicDatabase] Started
                      [INFO,DefaultDS] Starting
                      [INFO,DefaultDS] XA Connection pool DefaultDS bound to java:/DefaultDS

                      Same portion of log from a clean instance:

                      [INFO,HypersonicDatabase] Starting
                      [INFO,Default] Server 1.6 is running
                      [INFO,Default] Press [Ctrl]+[C] to abort
                      [INFO,HypersonicDatabase] Database started
                      [INFO,HypersonicDatabase] Started
                      [INFO,DefaultDS] Starting
                      [INFO,DefaultDS] XA Connection pool DefaultDS bound to java:/DefaultDS
                      [INFO,DefaultDS] Started


                      The first line from both the logs is the last line where the logs were the same. So the bind exception would seem to indicate that the XA Connection pool is unable to bind to the DefaultDS (datasource). And I'm guessing it's because the HypersonicDB is still in use or the port that it was using has not been made available from the last time the server was brought up.

                      Anyway, just some more info in case someone else out there is aware of and JBoss/Datasource issues and know a work around or fix.

                      Thanks,
                      Ed Ludke

                      • 8. Re: JBoss-2.4.4_Tomcat-4.0.1-beta just HANGS
                        Adrian Brock Master

                        I've seen this reported quite a few times in the past.
                        It is normally down to incorrect url config.
                        But it does occur in other circumstances.
                        I've never seen it myself.

                        The problem is XADataSourceLoader is configured
                        (by default) to wait forever for any connection.

                        This means a bad database connection gets stuck in
                        synchronized socket code and when you try to shut the
                        server down, the database part doesn't stop. The stop
                        code is locked out.
                        You then try to restart and you get a JVM_BIND error
                        because the previous version is still running.

                        I've seen a solution posted that stops the connection
                        waiting forever, but I couldn't find it in the search. :-(

                        From memory, I think it is the "Blocking" attribute
                        in jboss.jcml, but don't quote me on that :-)

                        I know JBoss3.0 has a new BlockingTimeOut Attribute set
                        to 5 secs by default, which is probably why I haven't
                        noticed this problem.

                        Regards,
                        Adrian

                        • 9. Re: JBoss-2.4.4_Tomcat-4.0.1-beta just HANGS
                          gong zin Newbie

                          Same here. I am using Redhat Linux 7.2, j2sdk 1.4.0, JBoss-2.4.4_Tomcat-4.0.1. Jboss just hangs. The funny thing is that I am using the same setting on a laptop(dual boot with windows 2000), and Jboss work in that environment. I don't see how Jboss can act differently on two machines with similar setting.

                          The URL for the DefaultDS is jdbc:hsqldb:hsql://localhost:1476

                          Any one knows if port 1476 could be used for some other services? I stopped every services I saw under Redhat. That still didn't fix the problem.

                          ?????

                          • 10. Re: JBoss-2.4.4_Tomcat-4.0.1-beta just HANGS
                            Paul Newbie

                            Here is how I fixed this problem. I though I had shut down my personal firewall, Zonealarm, to make the JBoss Server startup go easier, but it only made things worse. Apparently ZoneAlarm does not completely turn off from the system tray. So when I tried to start up JBoss with Catalina and kept ZoneAlarm running I got notices that an application was trying to act as a service. I granted all requests for access while the JBoss startup .bat file was running. This brought up JBoss without locking at the
                            [INFO,DefaultDS] XA Connection pool DefaultDS bound to java:/DefaultDS
                            line.

                            HTH

                            • 11. Re: JBoss-2.4.4_Tomcat-4.0.1-beta just HANGS
                              Chris Newbie

                              totaly new to Jboss so maybe everybody has got this covered but,

                              i had the problem with JBoss hanging while it was starting the database / registering the datasources etc.

                              and i found the this didn't happen if the path to jboss didn't include any directories with spaces in them

                              ie

                              c:\Program Files\JBoss --- hangs and don't work

                              c:\JBoss --- starts up fine

                              • 12. Re: JBoss-2.4.4_Tomcat-4.0.1-beta just HANGS
                                Jim Rand Newbie

                                do a "su" and the problem goes away before starting up JBoss.

                                If you don't want to do that, try doing a chmod u+w on all the files in jboss/db/hypersonic