4 Replies Latest reply on Jan 8, 2002 5:48 PM by Franco

    jndi.properties

    Franco Apprentice

      Hello the standard jndi.properties says:

      # Do NOT uncomment this line as it causes in VM calls to go over
      # RMI!
      #java.naming.provider.url=localhost

      But if uncomment it, the client is trying to connect to JBoss over IIOP.
      What I'm doing wrong ?

      Thanks for help.
      Franco

        • 1. Re: jndi.properties
          Juergen Heidak Newbie

          As far as I understand this comment it only affects the way how calls from one EJB to another are handled by jboss. If the line is uncommented such calls will go over RMI which is much slower than calling the object (in the same VM) directly.

          In my very own opinion this setting should not affect the way a client connects to the jboss server.

          • 2. Re: jndi.properties
            Franco Apprentice

            Thanks for the answer,

            now my stupid question:
            A SessionBean (on server) that access an EJB whitch protocol should it use if not RMI ?

            Thanks

            • 3. Re: jndi.properties
              Juergen Heidak Newbie

              It depends upon if the accessed EJB should also be available for "normal" clients.

              In EJB 1.1 each call from one EJB to another goes over RMI and this caused remarkable performance problems.

              Since EJB 2.0 there's a possibility to define local interfaces to tune performance. Methods defined in this local interfaces can be processed (by the application server) as "normal" java method calls which is much faster than a RMI request.

              See the specification (version 2.0) for details.

              • 4. Re: jndi.properties
                Franco Apprentice

                Thanks for the answer,
                do you know if this is implemented in 2.4.3 ?

                Ciao,
                Franco.