1 Reply Latest reply on Jan 23, 2002 4:45 PM by Deepak U Pai

    Cannot start tomcat with jboss configuration

    Richard Li Newbie

      Hi All,

      I have installed JBoss2.4 with embedded Tomcat 3.2.3 on SuSE linux 7.3. I run into trouble to start Tomcat. The error message is attached as following:

      ***********************************************
      ERROR reading /usr/local/JB/tomcat/conf/server.xml
      At Line 124 /Server/ContextManager/ContextInterceptor/ className=org.jboss.tomcat.naming.JbossWebXmlReader

      FATAL: configuration error
      java.lang.ClassNotFoundException: org.jboss.tomcat.naming.JbossWebXmlReader
      at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
      at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:286)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
      at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:315)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:120)
      at org.apache.tomcat.util.xml.ObjectCreate.start(XmlMapper.java:580)
      at org.apache.tomcat.util.xml.XmlMapper.matchStart(XmlMapper.java:384)
      at org.apache.tomcat.util.xml.XmlMapper.startElement(XmlMapper.java:81)
      at com.sun.xml.parser.Parser.maybeElement(Parser.java:1391)
      at com.sun.xml.parser.Parser.content(Parser.java:1499)
      at com.sun.xml.parser.Parser.maybeElement(Parser.java:1400)
      at com.sun.xml.parser.Parser.content(Parser.java:1499)
      at com.sun.xml.parser.Parser.maybeElement(Parser.java:1400)
      at com.sun.xml.parser.Parser.parseInternal(Parser.java:492)
      at com.sun.xml.parser.Parser.parse(Parser.java:284)
      at javax.xml.parsers.SAXParser.parse(SAXParser.java:155)
      at javax.xml.parsers.SAXParser.parse(SAXParser.java:126)
      at org.apache.tomcat.util.xml.XmlMapper.readXml(XmlMapper.java:214)
      at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:187)
      at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:235)
      *****************************************************
      I use jdk1.3.1 on the linux box. In addition, I encountered the same problems on Win2K. I wonder if anybody had the similar experience or has any clues what are the potential causes for this error. Thank you!