1 Reply Latest reply on Feb 6, 2002 5:00 AM by Manu

    Jboss2.4.4/4.0.1 versus 2.4.3/3.2.3

    Axel Muench Newbie

      Yes, this is mainly a Linux setup issue for JBoss 2.4.4/ Catalina - I have read all the threads including the FAQs out there and still have two unresolved issues. So please bear with me for a second here.

      JBoss 2.4.3/Tomcat 3.2.3 no problems. '127.0.0.1:8080/jboss' and '127.0.0.1:8080' access work fine.

      My problem is around the the JBoss 2.4.4/Catalina 4.0.1 setup. Accessing '127.0.0.1:8080/jboss' works fine. Accessing '127.0.0.1:8080' doesn't.
      Now I understand that in various threads to resolve this was adding a new .war or .ear file and specifying a different path like 'test' or taking the Catalina examples and deploy those in a .war file. I tried altering the 'tomcat-test.ear' example or adding my own '.war file'. No luck here, it doesn't seem to deploy them. (Problem 1)

      I deleted the 'tomcat-test.ear' file and JBoss seems to be still able to deploy it.

      Now when I compare the JBoss/Tomcat against the JBoss/Catalina setup ther are no .war files inside the jboss/deploy-directory necessary in the Tomcat setup to be able to access '127.0.0.1:8080' or '127.0.0.1:8080/examples'.
      (Problem 2).

      Thanks for any advise.


        • 1. Re: Jboss2.4.4/4.0.1 versus 2.4.3/3.2.3
          Manu Newbie

          Hi,

          I have a similar configuration as yours though I have not tried the JBoss 2.4.3/Tomcat 3.2.3 version.

          I am attaching the modified version of tomcat-test.ear. The only difference is that the context-root in application.xml is '/' and not '/jboss'. Try putting in deploy directory and it shud work.

          About the second problem, try deleting the subdirectories under JBoss-2.4.4_Tomcat-4.0.1/jboss/tmp/deploy and restart jboss.

          Hope that helps.

          Regards
          Manu