2 Replies Latest reply on Apr 14, 2008 8:58 AM by Ilya Shaikovsky

    datatable rerender problem

    Sebastián Ressi Newbie

      I'm using richfaces 3.1.3.
      I'm having trouble with dynamic datatables. There's an ajax delete row button in each row and the problem is that when this button is clicked, everything in the table is rerendered ok excpet for the row where this button is clicked. For this row the update is not done, I still can see the deleted data on the screen, request calls for all inputs inside this row are not executed.
      Here's the code:

      <rich:dataTable onRowMouseOver="this.style.backgroundColor='#F1F1F1'"
       onRowMouseOut="this.style.backgroundColor='#{a4jSkin.tableBackgroundColor}'"
       cellpadding="0" cellspacing="0" id="table" width="500" rows="10" first="#{coleccionesDTO.row}"
       border="0" var="item" value="#{coleccionesDTO.sectores}" align="center" columns="3" columnClasses="centro,centro,centro">
       <f:facet name="header">
       <rich:columnGroup>
       <rich:column>
       <h:outputText value="Nº" />
       </rich:column>
       <rich:column>
       <h:outputText value="Name" />
       </rich:column>
       <rich:column>
       <h:outputText value="Delete" />
       </rich:column>
       </rich:columnGroup>
       </f:facet>
       <rich:column>
       <h:outputText value="#{item.id}" />
       </rich:column>
       <rich:column>
       <h:inputText label="Nombre" value="#{item.nombre}" size="70" styleClass="forminput" required="true">
       <a4j:support event="onchange" reRender="err" ajaxSingle="true"/>
       </h:inputText>
       </rich:column>
       <rich:column>
       <t:panelGrid align="center" columns="1">
       <a4j:commandButton id="delete" title="DeleteRow" action="#{coleccionesDTO.delSectores}" reRender="table" image="/img/icons/delete.gif" immediate="true">
       <t:updateActionListener property="#{coleccionesDTO.index}" value="#{item.index}" />
       </a4j:commandButton>
      
       </t:panelGrid>
       </rich:column>
       </rich:dataTable>


      I've tryed everything to solve this issue but I still can't find the solution. Is there any problem with this version of richfaces?. Thanx.