1 Reply Latest reply on Apr 14, 2002 9:45 AM by David Jencks

    JBoss 3 beta and MySql configuration

    Sean Radford Novice

      Hi,

      I'm trying to configure a datasource to a mysql database but don't seem to be having any luck.

      In the console I get:

      11:37:42,962 INFO [MainDeployer] Deploying: file:/C:/bosscat/jboss-3.0.0beta/deploy/gehr4j.xml

      And in the server.log it states that there is no deployer and then says 'done deploying'. I imagine that this is correct but there is no log messges from [org.jboss.resource.ConnectionFactoryLoader] stateing that it is creating/starting a connection (as happens with the DefaultDS (Hypersonic).

      My 'mysql service file' (called gehr4j.xml and in the 'deploy' directory) is:

      <?xml version="1.0" encoding="UTF-8"?>






      ConnectionURL=jdbc:mysql://blade.agora.co.uk/gehr4j
      DriverClass=org.gjt.mm.mysql.Driver
      UserName=sa_gehr4j

      gehr4jDS
      java:/TransactionManager
      <depends optional-attribute-name="ResourceAdapterName">jboss.jca:service=RARDeployment,name=Minerva JDBC LocalTransaction ResourceAdapter
      <depends optional-attribute-name="ConnectionManagerFactoryLoaderName">jboss.jca:service=ConnectionManagerFactoryLoader,name=MinervaSharedLocalCMFactory

      MinSize=0
      MaxSize=10
      BlockingTimeoutMillis=5000
      IdleTimeoutMinutes=30
      CleanupIntervalMinutes=10
      MaxIdleTimeoutPercent=1.0


      org.jboss.resource.security.ManyToOnePrincipalMapping

      UserName=sa_gehr4j Password=password




      Any ideas?

      Regards,

      Sean