3 Replies Latest reply on Apr 23, 2002 4:47 PM by Alex Sauve

    I wanna use Xalan and Xerces

    ditto Newbie

      hey folks,
      I want to use xalan and xerces in my application but this default crimson.jar make my life hell by throwing this exception..

      java.lang.ClassCastException: org.apache.crimson.jaxp.DocumentBuilderFactoryImpl

      I tried to modify the run.bat but no success.
      Come on brainy guys help me to hit the ball in right direction.

      Ditto.

        • 1. Re: I wanna use Xalan and Xerces
          ditto Newbie

          Hey guys,
          There is litte success by modifying the the following lines in run.bat ..
          REM Add the XML parser jars and set the JAXP factory names
          REM Crimson parser JAXP setup(default)
          set JBOSS_CLASSPATH=%JBOSS_CLASSPATH%;../lib/xalan.jar;../lib/xerces.jar;../lib/xml-apis.jar;
          REM set JAXP=-Djavax.xml.parsers.DocumentBuilderFactory=org.apache.crimson.jaxp.DocumentBuilderFactoryImpl
          REM set JAXP=%JAXP% -Djavax.xml.parsers.SAXParserFactory=org.apache.crimson.jaxp.SAXParserFactoryImpl
          set JAXP=-Djavax.xml.parsers.DocumentBuilderFactory=org.apache.xerces.jaxp.DocumentBuilderFactoryImpl
          set JAXP=%JAXP% -Djavax.xml.parsers.SAXParserFactory=org.apache.xerces.jaxp.SAXParserFactoryImpl
          set JAXP=%JAXP% -Djavax.xml.transform.TransformerFactory=org.apache.xalan.processor.TransformerFactoryImpl

          but facing another headeache, the encoding "Cp1252" is
          not supported.I modified my EJB to UTF-8 encoding but i'm blinking and thinking how to make change in third party jar files(EJB) encoding.Any thoughts???

          Ditto.

          • 2. Re: I wanna use Xalan and Xerces
            ditto Newbie

            Cool! i can modify the Third party EJB Deployment Descriptior also.It seems now working.

            Thanks,
            Ditto

            • 3. Re: I wanna use Xalan and Xerces
              Alex Sauve Newbie

              Does anyone have a sample of the third party deployment descriptor that one would need to get rid of this error???

              Thanks,
              Alex