1 Reply Latest reply on Aug 2, 2002 8:36 PM by Mark LaPolla

    seriously frustrated - Apache and JBOSS+Tomcat 4.0

    Alex Sauve Newbie

      I know that this subject has been discussed to death, but I am trying to integrate Apache 1.3.12 (I know that it is ancient) and JBOSS 2.4.4 + Tomcat 4.0.1. With very little success, I have all the configuration files set and I have Apache communicating thought the mod_jk.so at least the mod_jk.log says that it is trying to connect to jboss, but I continually get a page not found error. I can contact the page (the test page in the installation located at /jboss) on port 8080 but not using port 80 and going through Tomcat. Before I get into my configuration I appreciate any help that you can give on this subject.

      On the httpd.conf
      ...
      #INCLUDE_SECTION_TOMCAT
      Include "/home/asauve/JBoss-2.4.4_Tomcat-4.0.1/catalina/conf/mod_jk.conf"
      #END_INCLUDE_SECTION_TOMCAT
      <VirtualHost _default_:80>
      SSLEngine off
      RewriteEngine on
      RewriteLog /opt/atreus/xlink/logs/RewriteLog.proxy
      RewriteLogLevel 2

      # this directive is set in order to avoid access to
      # directory listing in the portal
      <Directory "/opt/atreus/portal/html">
      Options -Indexes


      #SECTION_TOMCAT
      JkMount /*.jsp apj13
      JkMount /jboss/* ajp13
      JkMount /jboss ajp13
      JkMount /sso/* ajp13
      JkMount /sso ajp13
      #END_SECTION_TOMCAT

      ProxyPass /authapi http://localhost:9442/authapi
      ProxyPass /xlink http://localhost:9442/xlink

      ProxyPass /portal http://localhost:9303/
      ProxyPass /portal/ http://localhost:9303/
      ProxyPass / http://localhost:9303/

      RewriteRule /portal/images(.*) /opt/atreus/portal/html/images$1
      RewriteRule /portal/js(.*) /opt/atreus/portal/html/js$1
      RewriteRule /images(.*) /opt/atreus/portal/html/images$1
      RewriteRule /js(.*) /opt/atreus/portal/html/js$1
      RewriteRule /css(.*) /opt/atreus/portal/html/css$1

      ProxyPassReverse /portal/ http://localhost:9303/
      ProxyPassReverse / http://localhost:9303/


      ...

      ---------------------------------------------------------
      /home/asauve/JBoss-2.4.4_Tomcat-4.0.1/catalina/conf/mod_jk.conf

      ########## Auto generated on Mon Jan 28 19:17:37 EST 2002##########

      <IfModule !mod_jk.c>
      LoadModule jk_module /opt/atreus/apache/libexec/mod_jk.so
      AddModule mod_jk.c


      JkWorkersFile "/home/asauve/JBoss-2.4.4_Tomcat-4.0.1/catalina/conf/workers.properties"
      JkLogFile "/home/asauve/JBoss-2.4.4_Tomcat-4.0.1/catalina/logs/mod_jk.log"

      JkLogLevel debug

      #JkMount /admin ajp13
      #JkMount /admin/* ajp13

      JkMount /examples ajp13
      JkMount /examples/* ajp13

      JkMount /jboss ajp13
      JkMount /jboss/* ajp13

      #JkMount /sso ajp13
      #JkMount /sso/* ajp13

      --------------------------------------------------------
      Going to skip the workers.properties file as I took that file from a Tomcat 3.3 installation and copied it over.
      --------------------------------------------------------

      Uncomment the catalina connector in
      /home/asauve/JBOSS.../catalina/conf/server.xml

      --------------------------------------------------------
      Added the ajp13 connector to the jboss.jcml

      <!--The embedded Tomcat-4.x setup with AJP13 connector -->








      I think that pretty much covers it... BTW I don't see any communication on port 8009 when using
      $tcpdump port 8009 - does this not use the IIOP protocol on top of an TCP/IP stack? or is Apache just not sending the packets? THANK YOU AGAIN!

      Alex