3 Replies Latest reply on Jun 26, 2002 10:31 AM by David Jencks

    jboss 3RC1 and Postgres

    Le Bris Estelle Newbie

      Hi,

      I try to create a pool for Postgres and at starting jboss
      it looks good but when I deploy an application I have this
      error:
      16:45:57,522 ERROR [EntityContainer] Exception in service lifecyle operation: create
      org.jboss.deployment.DeploymentException: Error: can't find data source: java:/PostgresDS; - nested throwable is: javax.naming.NameNotFoundException: PostgresDS not bound
      javax.naming.NameNotFoundException: PostgresDS not bound
      at org.jnp.server.NamingServer.getBinding(NamingServer.java:495)

      ....



      My postgres-service.xml is:

      <?xml version="1.0" encoding="UTF-8"?>
      <!-- $Id: postgres-service.xml,v 1.3 2002/03/01 00:02:00 d_jencks Exp $ -->


      <!-- ===================================================================== -->
      <!-- -->
      <!-- Example configuration for the postgres database. -->
      <!-- Put the driver jar jdbc7.0-1.2.jar in lib/ext -->
      <!-- Contributed by Ignacio Coloma icoloma@iverdino.com -->
      <!-- ===================================================================== -->







      ConnectionURL=jdbc:postgresql://localhost:5432/foo
      DriverClass=org.postgresql.Driver
      UserName=postgres
      Password=postgres
      PostgresDS
      java:/TransactionManager
      <depends optional-attribute-name="ResourceAdapterName">jboss.jca:service=RARDeployment,name=Minerva JDBC LocalTransaction ResourceAdapter
      <depends optional-attribute-name="ConnectionManagerFactoryLoaderName">jboss.jca:service=ConnectionManagerFactoryLoader,name=MinervaSharedLocalCMFactory #
      #Wed Aug 15 16:17:29 EDT 2001
      BlockingTimeoutMillis=500000
      IdleTimeoutMinutes=30
      MaxSize=10
      CleanupIntervalMinutes=10
      MinSize=0
      MaxIdleTimeoutPercent=1.0


      org.jboss.resource.security.ManyToOnePrincipalMapping

      UserName=iris
      password=








      My standard-jaws.xml is:

      <?xml version="1.0" encoding="UTF-8"?>

      <!DOCTYPE jbosscmp-jdbc PUBLIC
      "-//JBoss//DTD JBOSSCMP-JDBC 3.0//EN"
      "http://www.jboss.org/j2ee/dtd/jbosscmp-jdbc_3_0.dtd">

      <!-- ===================================================================== -->
      <!-- -->
      <!-- Standard Jaws Configuration -->
      <!-- -->
      <!-- ===================================================================== -->

      <!-- $Id: standardjaws.xml,v 1.27 2002/03/24 21:44:32 d_jencks Exp $ -->


      java:/PostgresDS
      <type-mapping>PostgreSQL</type-mapping>
      false
      .....


      My standard-jbosscmp-jdbc.xml is:

      <?xml version="1.0" encoding="UTF-8"?>
      <!DOCTYPE jbosscmp-jdbc>

      <!-- ===================================================================== -->
      <!-- -->
      <!-- Standard JBossCMP-JDBC Configuration -->
      <!-- -->
      <!-- ===================================================================== -->

      <!-- $Id: standardjbosscmp-jdbc.xml,v 1.23 2002/04/14 17:35:31 dsundstrom Exp $ -->

      <jbosscmp-jdbc>


      java:/PostgresDS
      <datasource-mapping>PostgreSQL</datasource-mapping>

      <create-table>true</create-table>

      ....

      Have you an idea of the problem ?

      Iris