9 Replies Latest reply on May 23, 2002 6:01 PM by george

    JBOSS 3.0 multiple instances

    alex Newbie

      Is it possible to run multiple instances of JBOSS 3.0?

        • 2. Re: JBOSS 3.0 multiple instances
          zx44093 Newbie

          By using different port or can we use different IP for each instance?

          • 3. Re: JBOSS 3.0 multiple instances
            george Newbie

            I try to run two Jboss 3.0 server in same machine, but not successful. What I did is just changed some conflict port numbers. Is there any other configurations we have to do?

            Thanks

            • 4. Re: JBOSS 3.0 multiple instances
              zx44093 Newbie

              By changing all the ports it should work. If you are sharing the same JBoss installation, it seems you have to specify a different tmp\deploy directory. Otherwise it will complain that some rar have already been deployed since the folder and file already existed. Read the com.jboss.Main.java, you may be able to pass it in as a parameter. Let me know if you get it to work.

              • 5. Re: JBOSS 3.0 multiple instances
                george Newbie

                Thank you for your reply. It's still not working.
                The JBoss-3.0.0RC2 I just modified jboss-service.xml and standardjboss.xml two file's port numbers. I copied whole default folder to new folder myjboss, then modified above two file in conf.
                When I start jboss use: run.bat myjboss

                there are some errors here:
                ERROR [JettyService] exception
                java.net.BindException: Address already in use: JVM_Bind
                at java.net.PlainSocketImpl.socketBind(Native Method)
                at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:321)
                and

                ERROR [HANamingService] Could not start on port 1100
                java.net.BindException: Address already in use: JVM_Bind
                at java.net.PlainSocketImpl.socketBind(Native Method)
                at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:321)
                at java.net.ServerSocket.bind(ServerSocket.java:308)

                but I could not find the port 1100.

                Could you find is there something I missed?

                Thanks

                • 6. Re: JBOSS 3.0 multiple instances
                  zx44093 Newbie

                  That's the port used by cluster and I guess it's hard coded since you do not want to change it and expect other servers be able to communicate with it. I did get 2.4.4 to work simply changing the ports.

                  I think the best way of doing this is using different IP for each instance. But I have not been able to figure out how to get it to work using bindAddress attribute yet. It may require a different network card instead of just add a virtual IP.

                  • 7. Re: JBOSS 3.0 multiple instances
                    zx44093 Newbie

                    Or, if you are not using cluster, why don't you simply disable the cluster service by removing it from deploy folder? If you do so, I bet it will work.
                    Good luck.

                    • 8. Re: JBOSS 3.0 multiple instances
                      zx44093 Newbie

                      Or you can try to add
                      ????
                      to the cluster-service.xml file. When the server starts, it may pick it up.

                      • 9. Re: JBOSS 3.0 multiple instances
                        george Newbie

                        Thank you for your reply.

                        I did turn off clustering service, and also modified file in conf jacorb.properties the OAPort number. Then Jboss started, but still some exceptions. like:

                        ERROR [OILServerILService] Starting failed
                        java.net.BindException: Address already in use: JVM_Bind
                        at java.net.PlainSocketImpl.socketBind(Native Method)
                        at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:321)
                        at java.net.ServerSocket.bind(ServerSocket.java:308)

                        ERROR [SARDeployer] start operation failed on package file:/C:/JBoss/jboss-3.0.0RC2-2/s
                        erver/default/deploy/jbossmq-service.xml
                        java.net.BindException: Address already in use: JVM_Bind
                        at java.net.PlainSocketImpl.socketBind(Native Method)
                        at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:321)
                        I think the JBoss-3.0.0RC2 there are some bugs for the server configurations. I'll try other versions later.

                        Thanks