0 Replies Latest reply on May 15, 2002 3:43 PM by Jeff Hall

    Cannot get Interest example to deploy and run

    Jeff Hall Newbie

      I've installed JBoss 3.00 RC2+Tomcat 4.0.3 and I'm trying to get the sample Interest application to deploy and run.

      Here's the session output:

      $ ant intro-interest-deploy
      Buildfile: build.xml

      validate-servlet:

      validate-jboss:

      fail_if_not_valid:

      init:
      [echo] Using JBoss directory=v:/tools/J2EE/jboss/JBoss-3.0.0RC2_tomcat-4.0.3
      [echo] Using base classpath=V:\tools\J2EE\jboss\JBoss-3.0.0RC2_tomcat-4.0.3\client\jboss-j2ee.j
      ar;V:\tools\J2EE\jboss\JBoss-3.0.0RC2_tomcat-4.0.3\client\jaas.jar;V:\tools\J2EE\jboss\JBoss-3.0.0RC
      2_tomcat-4.0.3\client\jbosssx-client.jar;V:\tools\J2EE\jboss\JBoss-3.0.0RC2_tomcat-4.0.3\client\jbos
      s-client.jar;V:\tools\J2EE\jboss\JBoss-3.0.0RC2_tomcat-4.0.3\client\jnp-client.jar;V:\tools\J2EE\jbo
      ss\examples\COULD_NOT_FIND_SERVLET_JAR
      [echo] Using Source directory=V:\tools\J2EE\jboss\examples
      [echo] Using Build directory=V:\tools\J2EE\jboss\examples/build-examples

      intro-interest-deploy:

      compile:

      ejb-jar:
      [delete] Deleting directory V:\tools\J2EE\jboss\examples\build-examples\interest\META-INF
      [mkdir] Created dir: V:\tools\J2EE\jboss\examples\build-examples\interest\META-INF
      [copy] Copying 1 file to V:\tools\J2EE\jboss\examples\build-examples\interest\META-INF
      [copy] Copying 1 file to V:\tools\J2EE\jboss\examples\build-examples\interest\META-INF
      [jar] Building jar: V:\tools\J2EE\jboss\examples\build-examples\interest\interest.jar

      deploy-ejb-jar:
      [copy] Copying 1 file to V:\tools\J2EE\jboss\JBoss-3.0.0RC2_tomcat-4.0.3\deploy

      BUILD SUCCESSFUL

      Total time: 2 seconds

      ** Nothing happens in the server console window! And why am I seeing V:\tools\J2EE\jbo
      ss\examples\COULD_NOT_FIND_SERVLET_JAR added to the classpath???

      If I enter the following command:

      $ cp interest.jar ../../../jboss-3.0.0RC2_tomcat-4.0.3/server/default/deploy/

      I see the following in the server console window:

      12:34:52,862 INFO [MainDeployer] Starting deployment of package: file:/V:/tools/J2EE/jboss/jboss-3.
      0.0RC2_tomcat-4.0.3/server/default/deploy/interest.jar
      12:34:53,096 INFO [EjbModule] Creating
      12:34:53,159 INFO [EjbModule] Deploying Interest
      12:34:53,331 INFO [EjbModule] Created
      12:34:53,331 INFO [EjbModule] Starting
      12:34:53,456 INFO [EjbModule] Started
      12:34:53,456 INFO [MainDeployer] Successfully completed deployment of package: file:/V:/tools/J2EE/
      jboss/jboss-3.0.0RC2_tomcat-4.0.3/server/default/deploy/interest.jar

      ** Now, when I try to run the client app, I get the following:

      $ ant intro-interest-client
      Buildfile: build.xml

      validate-servlet:

      validate-jboss:

      fail_if_not_valid:

      init:
      [echo] Using JBoss directory=v:/tools/J2EE/jboss/JBoss-3.0.0RC2_tomcat-4.0.3
      [echo] Using base classpath=V:\tools\J2EE\jboss\JBoss-3.0.0RC2_tomcat-4.0.3\client\jboss-j2ee.j
      ar;V:\tools\J2EE\jboss\JBoss-3.0.0RC2_tomcat-4.0.3\client\jaas.jar;V:\tools\J2EE\jboss\JBoss-3.0.0RC
      2_tomcat-4.0.3\client\jbosssx-client.jar;V:\tools\J2EE\jboss\JBoss-3.0.0RC2_tomcat-4.0.3\client\jbos
      s-client.jar;V:\tools\J2EE\jboss\JBoss-3.0.0RC2_tomcat-4.0.3\client\jnp-client.jar;V:\tools\J2EE\jbo
      ss\examples\COULD_NOT_FIND_SERVLET_JAR
      [echo] Using Source directory=V:\tools\J2EE\jboss\examples
      [echo] Using Build directory=V:\tools\J2EE\jboss\examples/build-examples

      intro-interest-client:

      compile:

      interest-client:
      [java] Got context
      [java] javax.naming.CommunicationException: unexpected block data [Root exception is java.io.St
      reamCorruptedException: unexpected block data]

      BUILD SUCCESSFUL

      Total time: 4 seconds

      ** What's going on??