2 Replies Latest reply on Jun 28, 2002 8:11 AM by Bruno Lowagie

    jBoss + Catalina + SSL

    Bruno Lowagie Newbie

      Hello,

      I tried to combine jBoss with Catalina over SSL.
      I followed every step in the FAQ and Forum I could find,
      but I stranded here:
      <A HREF="http://www.jboss.org/modules/bb/index.html?module=bb&op=viewtopic&t=forums/ entry 1
      and
      <A HREF="http://www.jboss.org/modules/bb/index.html?module=bb&op=viewtopic&t=forums/ entry 2

      I get the same error as described in the Forum, so I changed class
      org.jboss.web.catalina.security.SSLServerSocketFactory:

      public ServerSocket createSocket(int port, int backlog, InetAddress ifAddress)
      throws IOException
      {

      if (socketFactory == null) throw new IOException("the socketFactory is null!");
      return socketFactory.createServerSocket(port, backlog, ifAddress);
      }

      Now I get:
      11:11:37,458 INFO [STDOUT] Apache Tomcat/4.0.3
      11:11:37,520 INFO [Engine] HttpConnector Opening server socket on all host IP addresses
      11:11:37,534 ERROR [EmbeddedCatalinaServiceSX] Starting failed
      LifecycleException: null.open: java.io.IOException: the socketFactory is null!

      So I was able to pinpoint the error: for some reason the socketFactory in class
      SSLServerSocketFactory is null. Can any of you help me any furher?

      Bruno