4 Replies Latest reply on Jul 12, 2002 9:49 PM by Julian Gosnell

    Jboss3.0 +Tomcat 4.0.3 + Struts1.0.2?

    Diego Celery Newbie

      Hi!
      I'm working with Jboss2.4.4 + Struts1.0.2 and all is OK.
      But not with Jboss3.0.
      I can't work in Jboss3.0 using Struts1.0.2
      anybody can help me?
      Please it's urgent.

      I have Struts.jar in my WEB-INF/lib of my WAR.
      I have an error ClassDefNotFound Action
      Thanks Diego

        • 1. Re: Jboss3.0 +Tomcat 4.0.3 + Struts1.0.2?
          Brian Law Newbie

          I've tried using struts in JBoss which deploy the application as EAR without problem.

          Pls desribe more about your situation.

          • 2. Re: Jboss3.0 +Tomcat 4.0.3 + Struts1.0.2?
            Neil Lamoureux Newbie

            I'm having the same problem with struts in JBoss 3.0.0 / Jetty / Struts 1.0.2.

            When I deploy as an .ear, I place struts.jar in /WEB-INF/lib in the war file. This results in:

            java.lang.NoClassDefFoundError: org/apache/struts/action/Action

            Note if I remove the .ear from the deploy directory and replace it with just its embedded .war in the deploy directory, it works fine. It seems the JBoss class loader can't find the .war's /WEB-INF/lib/ jars when the .war is embedded in a .ear, but can find it when the .war is stand-alone.

            A work-around is to place the struts.jar file in jboss-3.0.0\server\default\lib. However, I don't think its good practice to put app-specific jars in a common lib for all apps you deploy.

            Does anyone know how to deploy struts.jar as part of the embedded .war in a .ear file?

            • 3. Re: Jboss3.0 +Tomcat 4.0.3 + Struts1.0.2?
              Iago Elizechea Newbie

              I have exactly the same problem. The problem is: I put the struts jar in the lib folder but, now, the server seems to be unable to find my other classes in then WEB-INF/classes. My project ear worked fine in JBoss-2.4.4 + Tomcat-4.0.1 but it doesn't work at all in jboss-3.0.0 + tomcat-4.0.3

              2002-07-12 12:39:48,873 ERROR [org.jboss.web.localhost.Engine] action: Error creating Action instance for path '/MainPage', class name 'moda.http.controller.actions.MainPageAction'
              java.lang.ClassNotFoundException: moda.http.controller.actions.MainPageAction

              • 4. Re: Jboss3.0 +Tomcat 4.0.3 + Struts1.0.2?
                Julian Gosnell Expert


                Guys,

                If one of you ever gets a struts app going to their satisfaction in JBoss/Jetty, would you report back to this forum. I'd like to distil the answer into an FAQ item, and save everyone else having to go through the pain I see here !!!

                Thanks for your understanding ;-)


                Jules