3 Replies Latest reply on Aug 18, 2002 2:28 AM by Ajith

    Problems launching JBoss-2.4.6_Tomcat-4.0.3  on RedHat Linux

    Ajith Newbie

      Hi! All,

      I need some help to understand what seems to be the
      problem here.please see the attached file.

      I am launching ./run.sh

      When I run the ./run_with_catalina.sh I don't see any problem and jboss comes up fine.
      I am strictly following the Reference Manual and see if it launches clean.


      Any help appreciated

      thanks,
      ajith

        • 1. Re: Problems launching JBoss-2.4.6_Tomcat-4.0.3  on RedHat L
          Ajith Newbie

          I seem to have a problem attaching the file.
          let me try again.

          • 2. Re: Problems launching JBoss-2.4.6_Tomcat-4.0.3  on RedHat L
            Jason Brome Newbie

            This is the important line in the log file:

            org.jboss.deployment.J2eeDeploymentException: application contains war files but no web container available

            In Jboss 2.4.x, executing run.sh brings up JBoss without the integrated web container - Tomcat 4.0.3 in your scenario.

            In your deploy directory you have an ear - webtest.ear - which if I read the logs right contains two wars - ROOT.war and examples.war.

            Therefore, JBoss 2.4.x is throwing an exception as you've started it without the Web container, but you're trying to deploy an ear that contains web apps.

            Starting JBoss with run_with_catalina.sh brings up JBoss 2.4.x with the web container, and therefore is able to deploy web applications.

            Jason

            • 3. Re: Problems launching JBoss-2.4.6_Tomcat-4.0.3  on RedHat L
              Ajith Newbie

              Hi! Jason,

              Thanks for the inside scoop.
              I could get it up with Catolina without a problem .
              As you see I am a new commer.

              I have been able to get jBoss 3.0 up and running.!!!
              Hen I managed to get the source and compile it successfully.

              when I try to run my JBoss bulid I run into problems.( please see below )

              I would like to play with some samples in my own environment rather than running just the server.Could you please see anything obvious here.
              [ajith@ns build]$ ./build.sh run-jboss
              Searching for build.xml ...
              Buildfile: /van/work/ajith/jboss/jboss-all/build/build.xml
              Trying to override old definition of task property

              _buildmagic:init:

              _buildmagic:init:local-properties:

              _buildmagic:init:buildlog:

              BUILD FAILED
              jar:file:/van/work/ajith/jboss/jboss-all/tools/lib/buildmagic-tasks.jar!/org/jboss/tools/buildmagic/common.xml:93: Problems creating a recorder entry

              Total time: 2 seconds

              -- ajith