2 Replies Latest reply on Sep 9, 2002 5:25 AM by Bruce Blackshaw

    Unable to launch JBoss3.0.1-Tomcat4.0.4

    John Muhlestein Newbie

      I am unable to get JBoss to start. It seems to almost finish initialization (It has successfully deployed the test .war file I have in the deploy directory) then fails and shuts down. Here is the relevent ERRORS from boot.log

      15:30:24,634 ERROR [URLDeploymentScanner] MBeanException: Exception in MBean operation 'checkIncompleteDeployments()'
      Cause: Incomplete Deployment listing:
      Packages waiting for a deployer:

      Incompletely deployed packages:

      MBeans waiting for classes:

      MBeans waiting for other MBeans:
      [ObjectName: jboss.system:type=Log4jService,service=Logging
      state: FAILED
      I Depend On:
      Depends On Me: org.jboss.deployment.DeploymentException: No property editor for attribute: ConfigurationURL; type=class java.net.URL]
      15:30:24,647 DEBUG [AbstractDeploymentScanner$ScannerThread] Notified that enabled: true
      15:30:24,648 INFO [URLDeploymentScanner] Started
      15:30:24,648 DEBUG [MainDeployer] End deployment start on package: jboss-service.xml
      15:30:24,649 INFO [MainDeployer] Deployed package: file:/var/jboss/jboss3.0.1/server/default/conf/jboss-service.xml
      15:30:24,650 ERROR [Server] start failed
      Incomplete Deployment listing:
      Packages waiting for a deployer:

      Incompletely deployed packages:

      MBeans waiting for classes:

      MBeans waiting for other MBeans:
      [ObjectName: jboss.system:type=Log4jService,service=Logging
      state: FAILED
      I Depend On:
      Depends On Me: org.jboss.deployment.DeploymentException: No property editor for attribute: ConfigurationURL; type=class java.net.URL]
      at org.jboss.deployment.MainDeployer.checkIncompleteDeployments(MainDeployer.java:1095)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:583)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:564)
      at java.lang.reflect.Method.invoke(Native Method)
      at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:491)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:324)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:221)
      at org.jboss.Main.boot(Main.java:142)
      at org.jboss.Main$1.run(Main.java:375)
      at java.lang.Thread.run(Thread.java:498)
      15:33:12,386 INFO [Server] Undeploying all packages


      Any ideas?

      thanks,
      John

        • 1. Re: Unable to launch JBoss3.0.1-Tomcat4.0.4
          Ryan Delano Newbie

          Hello John,

          I had this exact same problem not too long ago. I don't know EXACTLY what was the cause because I had a bunch of problems and had to deal with them all in the same day or two. That being said, here is what I think caused the specific problem you are showing here.

          There i likely to be a bug or incompatibility with the version of Java you are running. I *think* I was running something like 1.3.0 or even 1.3.1_02. There is a problem that prevents some class loader from finding the class that supports the log4 logging. I upgraded to 1.3.1_04 and like magic it went away. Before I upgraded I simply disabled the logging -BUT- you'd just run on to the next class-not-found error due to the same class loader incompatibility.

          If by chance you already have that JDK version then I expect you have a path/classpath problem.

          Once that logger problem went away I may have hit another, but I was able to complete my installation & config by filling in a few ENV variable gaps after skimming this page: http://www.csd.abdn.ac.uk/~bscharla/JBossTomcatInstall.html

          Please let us know if the move to JDK 1.3.1_04 (or better) helps. As I recall that was the exact cause (class loader conflict) and solution(JDK upgrade).

          Good luck,
          Ryan

          • 2. Re: Unable to launch JBoss3.0.1-Tomcat4.0.4
            Bruce Blackshaw Newbie

            I've had a similar problem, that turned out to be not running run.sh from the jboss/bin directory. Must be some relative paths in the script ...

            bruce
            ---------------------------
            Free Java FTP Library
            http://www.enterprisedt.com/downloads/ftp.html