2 Replies Latest reply on Sep 9, 2002 3:06 PM by jack wu

    jboss-3.0.2 problem at server start up

    jack wu Newbie

      jdk: sun 1.3. windows NT 4.0 service pack 6.

      download jboss-3.0.2.zip, unzip, go to jboss/bin and
      execute run.bat with no option and receive the following exception:

      ......
      14:49:24,234 INFO [ServiceConfigurator] Problem configuring service jboss:type=
      Service,name=SystemProperties
      org.jboss.deployment.DeploymentException: No property editor for attribute: Prop
      erties; type=class java.util.Properties
      at org.jboss.system.ServiceConfigurator.configure(ServiceConfigurator.ja
      va:328)
      at org.jboss.system.ServiceConfigurator.internalInstall(ServiceConfigura
      tor.java:187)
      at org.jboss.system.ServiceConfigurator.install(ServiceConfigurator.java
      :130)
      at org.jboss.system.ServiceController.install(ServiceController.java:224
      )
      at java.lang.reflect.Method.invoke(Native Method)
      at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBea
      nDispatcher.java:284)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:517)
      at org.jboss.util.jmx.MBeanProxy.invoke(MBeanProxy.java:174)
      at $Proxy3.install(Unknown Source)
      at org.jboss.deployment.SARDeployer.create(SARDeployer.java:209)
      at org.jboss.deployment.MainDeployer.create(MainDeployer.java:755)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:615)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:580)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:564)
      at java.lang.reflect.Method.invoke(Native Method)
      at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBea
      nDispatcher.java:284)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:517)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:324)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:221)
      at org.jboss.Main.boot(Main.java:142)
      at org.jboss.Main$1.run(Main.java:375)
      at java.lang.Thread.run(Thread.java:484)

        • 1. Re: jboss-3.0.2 problem at server start up
          Ryan Delano Newbie

          Hello Jack,

          I too encountered this error a while back. I believe the solution was to upgrade to JDK 1.3.1. If you do try this for lack of a better option, I suggest 1.3.1_04 because I've read about and experienced some funky incompatibility with 1.3.1_02 or less. (The funk was that the ClassLoader was not recognizing/finding a ton of classes leading to a stream of ClassDefNotFound errors.) I have no experience with 1.4.0 so I can't speak for that though I expect it would work too.

          Good luck and please let us know if that clears it up so others will know whether or not to do the same.
          Thanks,
          Ryan

          • 2. Re: jboss-3.0.2 problem at server start up
            jack wu Newbie

            right. the problem went away after i switched to jdk1.3.1_04. Thanks.