3 Replies Latest reply on Sep 24, 2002 9:03 AM by Hugo de Vaan

    Apache 2 and JBoss 3 don't cooperate

    Hugo de Vaan Newbie

      Hi,

      After reading instructions found on http://www.pubbitch.org/jboss/mod_jk2.html I've downloaded the mod_jk2.dll file, put that in the /modules folder of Apache 2 and then I've added the following in the Apache 2 httpd.conf file:
      LoadModule jk2_module modules/mod_jk2.dll
      JkMount /*.jsp worker1

      When starting the Apache httpd service, it bombs with the message "Invalid command 'JkMount', perhaps mis-spelled or defined by a module not included in the server configuration."

      Can anyone give me instructions on how to get JBoss 3 to work together with Apache 2 on a Windows 2000 machine? Is this even possible? Or is JBoss really a product for the UNIX/Linux community?

        • 1. Re: Apache 2 and JBoss 3 don't cooperate
          Hugo de Vaan Newbie

          UPDATE:

          I've got JBoss 3 up and running on the Win2000 machine (yihaa), but Apache refuses to work with the mod_jk2 DLL. I'll try to use the 'old' mod_jk DLL instead, because at least that stands a chance of working...

          By the way: I've got Tomcat 4.1.10 up and running smoothly in combination with IIS 5.1 on a WinXP machine. Maybe this is a known issue, maybe it isn't, but I'd like to report that JBoss does not work under WinXP AT ALL. I get an incompatible class version exception with both J2SDK 1.3.1 and 1.4.0...

          • 2. Re: Apache 2 and JBoss 3 don't cooperate
            Alexander Petty Newbie

            JBoss is not windows or linux/unix specific. Its entirely JAVA platform specific, wherever a JVM is running, so too may run JBOSS.

            Your problems running it under XP are probably based on your configuration of the Java environment on that box.

            -Alex

            • 3. Re: Apache 2 and JBoss 3 don't cooperate
              Hugo de Vaan Newbie

              What could be wrong with the Java environment for such an exception to occur? Bare in mind that Apache Tomcat 4.1.10 is running smoothly on the exact same WinXP machine where JBoss fails to start up. I've got J2SDK 1.4.0 on that machine...

              I'm wondering if there are people who've got JBoss 3 running properly under WinXP. I'd like to exchange configuration details with them to find out what's going on...