0 Replies Latest reply on Sep 27, 2002 1:23 PM by Aron Benett

    JBoss + Jetty & Turbine/Velocity

    Aron Benett Newbie

      Hi,

      I am currently running JBoss + Jetty with Apache Turbine/Velocity and have the following problem:
      Turbine expects the context mapping to be of the form
      http://localhost:8080/CONTEXT/servlet/MAPPING/template.vm
      for my app it is
      http://localhost:8080/MPAgreements/servlet/MPAgreements/index.vm

      When I run under the JBoss + Tomcat installation everything works fine. When I access the servlet context I get http://localhost:8080/CONTEXT/servlet/MAPPING
      When I run under Jetty and access the servlet context it returns me http://localhost:8080/CONTEXT/servlet
      It seems to be leaving off the MAPPING portion of the URL.

      According to the Turbine context home page at http://jakarta.apache.org/turbine/turbine-2/howto/url-rewriting-howto.html the url defined by the servlet api is http://www.foo.com/CONTEXT/servlet/MAPPING.
      I can get this to work by appending my application's MAPPING to the context everytime I access it but would rather not do this as it would the tie my templates to a specific application name.

      Can anybody help me with this. Does anyone know how to redefine the path info created by Jetty or JBoss. Is anyone else using Turbine and Velocity with JBoss + Jetty. Is anyone using Struts and Velocity with JBoss + Jetty as I would imagine that there is a similiar problem.

      Thanks,

      Aron