1 Reply Latest reply on Oct 9, 2002 2:00 PM by prabhakar chaganti

    Bug in XML parser loading??

    Jose Gonzalez Newbie

      I recently tried to deploy webwork 1.2.1 in Jboss3.0.3-Tomcat4.1.12. First time I tried it, I got an error from the saxon parser when JBoss was trying to read the tag library descriptor included in webwork. It seemed that the saxon parser, included with webwork (in WEB-INF/lib), was taking precedence and being used by JBoss to parse the descriptor. As this parser doesn't validate, it was throwing an exception when it was requested to parse the descriptor.

      After that I removed the saxon parser from webwork, redeployed and got the same error. I searched for saxon.jar and found it in a work directory of JBoss. After removing it, I could deploy the application correctly (with someother minor modification regarding configuration of log4j in webwork).

      Is normal and correct that an xml parser included in the WEB-INF/lib of a web application takes precedence over the xml parser used by JBoss when deploying an application? This seems to be a bug, what do you think? Should I post this message in any other place?

        • 1. Re: Bug in XML parser loading??
          prabhakar chaganti Apprentice

          That is how the Tomcat class loading works. Your web-inf/lib will override tomcat's loaded classes. So you can use different versions of xml parsers for tomcat itself, and separate ones for your app.

          But the jboss version 3.0 uses the unified class loading architecture(See Scott's post in the documentation forum?? detailing this). In this case, Jboss should use the already loaded parser for the descriptors and not the one in WEB-INF/lib.

          Any one else have any thoughts on this ?

          -prabhakar