2 Replies Latest reply on Jan 17, 2003 9:53 AM by Adrian Brock

    ClassNotFound in JBoss3.0.3_tomcat4.1.12

    Baloo Brahm Newbie

      Hello,

      I deployed a .ear that contains my war file. It is working in
      JBoss-2-4.3_Tomcat-3.2.3 but not JBoss.3.0.3_tomcat-4.1.12. It started complaining about not able to find ActionFromBean (a deprecated api). I added it to the server/default/lib
      directory and that message disappeared. Then, however, it started complaining about not being able to find an action class. The welcome.jsp page displays fine. I am using Struts 1.0 and I use Ant1.5 to create the war and ear files.

      I believe the directory structure is correct (cause the application has been working in the previous version.

      Does this have to do with ClassLoader? How can I get around this?

      Any help is appreciated.

      Here is the trace:
      -----------------------------------------------------
      14:09:08,645 ERROR [Engine] action: No action instance for path /Index could be
      created
      14:09:08,645 ERROR [Engine] action: No action instance for path /Index could be
      created
      java.lang.ClassNotFoundException: com.mycompany.myapp.action.Index
      at org.jboss.mx.loading.UnifiedLoaderRepository2.loadClass(UnifiedLoader
      Repository2.java:166)
      at org.jboss.mx.loading.UnifiedClassLoader.loadClass(UnifiedClassLoader.
      java:283)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
      ...
      -----------------------------------------------------