1 Reply Latest reply on Nov 12, 2002 5:48 PM by Tony Perkins

    Error: server VM not supported

    Tom Lauren Newbie

      I'm trying to run JBoss 3.0.4 on an SGI Origin 3400 running the Irix 6.5 OS with the 1.4.0 JVM. When I try to run "run.sh", I get the following ouput:

      Error: server VM not supported

      JBoss 3.0.4 runs fine on the same platform with the 1.3.1 JVM instead of the 1.4.0 JVM. I tried searching through the JBoss source code to find where this message originated, but had no luck.

      Any suggestions?

        • 1. Re: Error: server VM not supported
          Tony Perkins Newbie

          You need to remove or comment this code in the run.sh file:

          # If JAVA_OPTS is not set and the JVM is HOTSPOT enabled, then the server mode
          if [ "x$JAVA_OPTS" = "x" -a "x$HAS_HOTSPOT" != "x" ]; then
          # MacOS does not support -server flag
          if [ "$darwin" != "true" ]; then
          JAVA_OPTS="-server"
          fi
          fi

          That should solve your problem.