6 Replies Latest reply on Dec 2, 2002 12:18 PM by ravi gupta

    jboss-3.0.4_tomcat-4.1.12 install problem

    bob bob Newbie

      I am new to JBoss and having some problems:

      I have Apache webserver(and Covalent SSL) running on port 80. This installation works fine.

      I now installed jboss-3.0.4_tomcat-4.1.12.
      When I start JBoss using the service which I installed with the help of http://www.jboss.org/servlet/JiveServlet/download/67-22195-3744719-950/JBOSS+as+NT+Service.txt,
      or when I run JBoss from run.bat in the bin directory an error occurs.

      (1) I do not think Tomcat is running. I get errors on the following pages...

      http://localhost:8080
      http://localhost:8080/examples/jsp/index.html

      The error is
      HTTP Status 500 - No Context configured to process this request


      (2) The following error occurs in the stdout.log.....

      10:23:38,170 INFO [Server] Shutting down the JVM now!
      10:23:38,170 INFO [Server] Undeploying all packages
      10:23:38,170 INFO [MainDeployer] Undeploying file:/D:/jboss-3.0.4_tomcat-4.1.12/server/default/deploy/jmx-console.war/
      10:23:38,170 INFO [EmbeddedCatalinaService41] undeploy, ctxPath=/jmx-console, warUrl=file:/D:/jboss-3.0.4_tomcat-4.1.12/server/default/deploy/jmx-console.war/
      10:23:38,170 INFO [Engine] StandardHost[localhost]: Removing web application at context path /jmx-console
      10:23:38,180 INFO [Engine] StandardWrapper[/jmx-console:HtmlAdaptor]: Waiting for 1 instance(s) to be deallocated
      10:23:38,200 ERROR [Engine] StandardWrapperValve[HtmlAdaptor]: Servlet.service() for servlet HtmlAdaptor threw exception
      java.lang.NullPointerException
      at org.jboss.jmx.adaptor.html.HtmlAdaptorServlet.invokeOpByName(HtmlAdaptorServlet.java:211)
      at org.jboss.jmx.adaptor.html.HtmlAdaptorServlet.processRequest(HtmlAdaptorServlet.java:80)
      at org.jboss.jmx.adaptor.html.HtmlAdaptorServlet.doGet(HtmlAdaptorServlet.java:55)

      Has anyone seen this before???

        • 1. Re: jboss-3.0.4_tomcat-4.1.12 install problem
          Amit Likhyani Newbie

          Bump. I have the same problem.

          • 2. Re: jboss-3.0.4_tomcat-4.1.12 install problem
            Donald Hamm Newbie

            Yes, this is because Tomcat is running under JBoss and thus is not using the server.xml file from Tomcat. What needs to happen is you need to deploy any app (examples etc) in the <JBOSS_DIST>\Server\Default\Deploy folder -- ususally as a .war folder (in my case, I had too deploy Axis in this manner). You may need to setup a web.xml file for this to work. Also, the JBoss 3.0 QSG (Quick Start Guide) has details about deploying apps under JBoss using Tomcat (I just found it today). This is in draft form but is available @ this site...

            • 3. Re: jboss-3.0.4_tomcat-4.1.12 install problem
              bob bob Newbie

              I now have myApp.war in the server/default/deploy directory. I also have a web.xml file in this directory.
              I still get the same error - no context. Mapping error???

              • 4. Re: jboss-3.0.4_tomcat-4.1.12 install problem
                Donald Hamm Newbie

                I just installed JBOSS/Tomcat on a new machine. Updated Tomcat to point to the full version (which I'm using now instead of the LE version which comes with JBOSS). Installed Axis, setup the Environment vars and classpath per instructions. I then created the axis.war dir in the
                &lt;JBOSS_DIST&gt;\server\default\deploy dir. Ran JBOSS and all worked. I then created a myapp.war dir in the same dir. Created an index.html page (simple) &lt;html&gt;&lt;b&gt;Hello&lt;/b&gt;&lt;/html&gt;. Started JBOSS, ran http://localhost:8080/myapp/ -- it worked fine. I don't know what your config is like but you'll need to make sure all environment vars are in place, classpath is there and maybe, replace the LE version with the full Tomcat version. Its not too bad to do. Just he Getting Started guide located on this site. Best of luck!

                • 5. Re: jboss-3.0.4_tomcat-4.1.12 install problem
                  Medhat Galal Newbie

                  Hi, I have same problem with tomcat, and solution didn't work for me.

                  I have RH 8.0 with jdk 1.4.1, but when i run 'run.sh' and server starts, I get message server is ok "but not kernel is running as in quickstart guide".

                  here's the problem, when i go to http://localhost:8082 , i get and error about nothing running at this port.

                  JAVA_HOME is set to jdk1.4.1 location but when i run java, it gives the gnu java compiler instead, although i checked the shell script and it runs from $JAVA_HOME\bin\java , which means it's running 1.4.1

                  any suggestions? should i run the jboss_init_redhat.sh and change proper path?

                  thanks in advance.
                  MG

                  • 6. Re: jboss-3.0.4_tomcat-4.1.12 install problem
                    ravi gupta Newbie

                    did anyone get the /manager application to work, it seems that it has a security issue, only if it is deployed under jboss .. if it is running under tomcat standalone, it works fine.

                    i think it cant recognize tomcat-users.xml

                    ideas?
                    thx
                    ravi gupta